Cursor does not change to reflect tool in use

Since last update my mouse cursor does not change to the tool I’m using at the moment.
To be more precise it changes for a brief second and gets back to default pointer.
Zoom, scaling, resizing, duplicating. Tried to restart app and computer.
Maybe it’s not critical bug, but lack of visual feedback makes this really annoying. I’m not sure if I have selected proper tool or not.
Cursor works fine in other apps.

I’m not allowed to upload video here (first post, i usually read here), so heres youtube link:

Anyone experiencing this?

My setup: macOS 14.0, Figma 116.14.6 (standalone).

1 Like

Hi @AdamPe are you seeing this across other supported browsers or the desktop app? Are you using an external monitor, can you try unplugging and plugging it back in to see if that helps. I would also recommend trying to restart your device as well.

Thanks for the replay @Ryan_52
As mention in OP I use standalone and already tried restarting. I do use external monitor but it was happening on laptop screen too. This was persistent since last update but I haven’t check this in a browser. I couldn’t find solution on my own so I finally decided to ask on the forum.
But! I have downloded an update today and it back to normal in Figma 116.14.7.

2 Likes

I am running into this issue on FigJam and Figma. I uninstalled and reinstalled the desktop app, though the problem persists.

It also occurs on the web browser.

I am on a later update: 116.15.4.

EDIT: Tried restarting my computer again and it resolved the issue.
EDIT Again: Not sure what causes it, but the issue returned.

I had the same issue on the standalone Figma app, and what solved it was closing Photoshop. For some reason, having both open at the same time makes Figma cursor act weird

1 Like

Still seeing this in my Figma Beta build.
I noticed it when commenting and not seeing the cursor reflect the comment UI. But, it was really problematic when trying to screen record a mobile prototype for a presentation. I usually record with a device on the prototype so that the cursor in the prototype is the circle rather than the arrow. I was seeing the same behavior that @AdamPe mentioned above - where it would show up as a the expected circle, and would then revert to the arrow. I had to roll with it due to timeline, but would have loved for the expected touch feeling UI.

I am still seeing it with comments, and rotating shapes. I can manage, but I wanted to share with my Figma angels. I am on MacOS and running Figma Beta Desktop App version 116.16.6. Hope you get it resolved. Thanks all!

Thanks for the details. I will share this with the internal team. Thank you!

1 Like

Okay. I actually updated my MacOS last night, and it looks like that resolved the issue. Thanks for the response, @y_toku.

1 Like

Also experiencing this issue. Will try some of the suggestions mentioned and edit my reply accordingly.
Seeing the issue on Desktop app and in browser (Chrome).

Running MacOS Sonoma 14.3; Figma 116.11.1 (managed by organization account); Using external monitor=Yes.

Update
Restarting my machine seems to have resolved the issue, I’ll re-edit this post if the issue returns. I also managed to update my Figma instance and am now running on 116.15.15.

Hi there,

If you can’t solve the issue after trying the suggested troubleshooting, please reach out directly to the support team with a copy of your file: https://help.figma.com/hc/en-us/requests/new.

Please make sure you use the email associated with your Figma account, include links to the file in question, and share access with support-share@figma.com. Don’t worry, inviting us to view your file won’t impact your billing.

Thanks,
Toku

1 Like

Thank you for saving me! Closing Photoshop fixed it for me! You saved me hours of troubleshooting!