Color and typography styles from library not showing

I have created a file containing components and styles that I would like to re-use in other files, so I published the library. When I include the library in another file, all the components etc. show up, but not the typography or color styyles. What am I missing?

1 Like

I’m having the same issue. Library is enable to show in all files, but in the file I’m working on only shows the library components but not the styles.

I would make sure the style name does not have . or _ prefix which hides it from publishing. You can also try making a small change on a color or text style such as add or change the description and try publishing again to see if that helps.

I’m having the same issue, I published the library, I can see the components but not the colors or the text styles. Has this been fixed?

Hi, it seems that they don’t show right away. But if i create a new text and select the 4 dots on text styles, it shows there. Same thing happens if I want to pick a color style. I hope it’s useful.

1 Like

Thanks this worked!
Tho … I wish Figma did not nest the asset styles in the 4 dot icon - this was not intuitive.

Color styles from the library not showing issue fixed. When you click the plus (+) button. It will pop up 2 options. Styles and variable. You have to choose styles and create name and value. Issue solved. Who will buy me a coffee?

I had the same issue. I removed and added the library again, and it worked!