Can't view flows in Figma app, but they are visible on Desktop

I’m building a few prototypes in one page, all with different flows. I can play these prototypes and view all the different Flows on the Desktop app. But I can’t view the flows on the Mobile App except for the ‘first’ flow.

When I hold down two fingers to open the prototype menu, the ‘Choose flow’ is disabled, so I can’t switch between the different flows that are available on Desktop prototypes view.

What I’ve tried:

  • I tried removing all ‘Sections’ within the page
  • I tried clearing app Cache
  • I tried uninstalling and reinstalling the Figma app
  • I tried renaming the flows

Worth mentioning that it used to work!
I’m on Android (One UI version 6.1, Android 14), no Figma app updates available.

Attached screenshot of me viewing the prototype flows on Desktop, but the ‘Choose Flows’ is disabled on Mobile app.

Screenshot_20240619_140946_Figma-2

Hi @Karen8, Thank you for reaching out about this. I really appreciate you taking the time to troubleshoot.

I tested on my Figma mobile app with two flows in one page. And I noticed that after you interact with the flow on the screen, then you can switch between flows from the prototype options menu.

Could you please try below steps on your side to see if you can switch between flow starting points?
Here’s the steps to access the switch between flows:

  1. Sign in to the Figma mobile app
  2. Tap the file and Click pages icon on the bottom left to move to the page including two flows (if needed)
  3. Click play icon on the bottom > In this point, if you open the prototype options menu you cannot choose flow since it grayed out like the screenshot you shared
  4. Interact the prototype showing in the screen
  5. Open the prototype options menu after interacting with the prototype
  6. Switch flow

However, I acknowledge that this process may be confusing and it seems not mentioned in our article View prototypes on a mobile device, so I’ll communicate internally about this.

Hope it clarifies a bit. Let us know if I misunderstood anything. If anyone has any additional suggestions or workaround please share here.

Thanks again for bringing this to our attention!

2 Likes

Thanks Junko, it’s not very intuitive, but that workaround works!

2 Likes

For added clarity, you need to not just interact with the prototype (interactive elements) but you need to navigate to a new screen and from that new screen switch the flow.

If you navigate to the new screen but then navigate back to the main (the start of the flow) it will remain greyed out.

Hope this gets fixed soon, but thankful to have such a well built app otherwise : ) Keep up the great work!