Can't merge my own approved branch

I created a branch as usual, asked for review, got approved, and now instead of the “merge” button it says that I must have editor permission to merge. Which is odd, because I created the branch and everything, I obviously have editor’s permission (I even went to check if I did). I had to ask a collegue to merge it for me.

Same issue here. I’m the document owner and can’t merge it without review, and and neither an editor can, even passing review.

Experiencing the same on my team on the desktop app. One of my team mates can merge and 2 of us can’t. We’re all on v 101.6 of the desktop app. However, I can merge the same branch when using the web app. Wondering if there’s a bug on the desktop app because I also started getting permission errors yesterday.

Just noticed that it happened because I got my Edit permissions removed in the file magically. This happened to us in another file to another person of our team yesterday. It might be the root cause of the problem.

Thanks for the reports, we’ll look into this ASAP. Can you DM me links to the branches where you’re having this issue?

Hi,

This should now be fixed. We identified the root cause and pushed a fix. You may need to refresh your tab in order to get the fix. Please let us know if you are still experiencing this issue after refreshing.

  • R.J.

@raquino I’m running into this same issue. I’ve attempted all the suggestions above, but still not able to merge my own branch even though I’m the owner of the file.

I am experiencing this issue right now.

Same issue right now( Owners/editors cannot merge their own branches. Only admin can afford it.

The same issue. Refreshing tab doesn’t help.

And I faced such a problem

Hi! Have the same issue right now.

BTW Thanks so much for the branching functionality :heart:

I have a branch in which I’ve made numerous updates. I am now trying to merge the branch back into the main document. It tells me “Conflicts with [file] must be resolved to merge this branch” – but there are no conflicts listed. There are a lot of elements with tags of “Added”, “Edited,” “Removed” – but none of these have any visible or flagged conflicts. Is this purely a bug? And is there a way to bypass this? I could send it to an approver for review but that was my only option.

Hi Matthew,

I’ll DM you for more details.

R.J.

1 Like

I used to be able to merge my own branches but now I get a message saying “Only editors can merge this branch.” I checked the main file and I do have edit access.

I quit and restarted Figma but it still doesn’t work.

Hi Tom,

I’ll DM you for more details.

R.J.

Hi! Are there any updates on this issue? Cause I have the same problem.

Thanks in advance :blush:

2 Likes

That’s how I resolved this issue in my team. Maybe it would help somebody :blush:

You need to be the editor not only of the file, but also of the whole team where you have the project with this file in which you want to merge you branch.

Experiencing the same issue. Cant seem to merge my own branch have edit permissions on the file and the org.

Hello, seems I’m experiencing the same issue, I can’t merge, After clicking “merge without approval” (file is mine so no approval needed) the file is not responding for some time and nothing merged after it’s back