Can’t edit the text layer while double clicking the text layer, or any kind of text

Double-clicking a text layer won’t let me edit it. The layer is not locked. This issue seemed to be resolved in past for other users, but the solution has not been mentioned in the thread. I am first time coming across this issue. Please guide.

2 Likes

I’m having the same issue, please advice on how to resolve this

1 Like

Me to…any help out there?

Hey Indu! Here are some troubleshooting steps:

  1. Layer Opacity: Ensure that the opacity of the text layer isn’t set to 0%. If it is, you won’t be able to see the text even if you’re in edit mode.
  2. Layer Visibility: Make sure the eye icon next to the text layer in the layers panel is not crossed out. If it is, the layer is hidden, and you might not be able to edit it.
  3. Nested Frames: The text layer might be inside multiple nested frames or groups. Sometimes, if there’s another layer or object on top of the text layer, it can prevent you from selecting the text layer. Try to isolate the text layer by moving other layers or objects out of the way.
  4. Masking: Check if the text layer is being used as a mask or is inside a mask group. If so, you might face difficulties editing it directly.
  5. Component Instances: If the text layer is part of a component instance, you might not be able to edit it directly. Instead, you’ll need to go to the main component (the master) to make changes.
  6. Plugins: Some plugins can interfere with Figma’s default behavior. If you have any plugins installed, try disabling them one by one to see if one of them is causing the issue.
  7. Browser or Desktop App: If you’re using Figma in a web browser, try switching to the Figma desktop app, or vice versa. Sometimes, browser extensions or issues can interfere with Figma’s functionality.
  8. Update Figma
  9. Restart

It will help if any of you can share the link to a design file where this problem occurs.

This is happening to me too. Very frustrating. The only workaround is selecting the text tool then editing the text. Double-clicking would be great though.

2 Likes

I just updated to Sonoma 14.0 and noticing this issue as well. Except it’s impacting all components, not just text

1 Like

I just updated to Sonoma , also happens this ,i think Figma has problem with Sonoma

I have the same issue. Did you find a solution @Sarah_Shuda ?

1 Like

I’m on Ventura yet - so I’m not sure it’s the OS. I did not find a solution yet no. Please let me know if any of you do!

1 Like

I found a solution. My problem was my Logitech Lift Mouse. I changed the speed of the double-clicking option to a slower setting and now I can magically edit text boxes in Figma. Could be worth looking at your mouse seeings with this issue?

1 Like

I still have this problem, Checked mouse, trackpad and system settings. Also updated Figma. nothing got changed. :sob:

If you select the text layer and press Enter (PC) or Return (Mac) it will enter edit mode. This should be useful if you can’t enable editing by double-clicking for whatever reason.

1 Like

same for me

I had a similar issue where I could use the Enter key and delete key, but not edit text in existing text boxes.

Oddly, I could create a new text box, type in it, but then not edit again afterwards…

I discovered (by a lot of trial and error and retracing my steps) that I have several keyboards installed on my Mac as I work in different languages. If I clicked to change language, suddenly the ability to type returned…

1 Like

I’m having the same problem, but including items that are not text. I created the component, but now it will not let me resize or edit ANY elements, defeating the purpose of having made it a component. I can click on an icon, I can press enter or K or whatever and bring up the edit menu, but the edit menu is grayed out and I can’t click on or interact with any part of it at all. This is maddening.

Hey @Heather_Harris, thank you for reaching out! I totally understand that this must be frustrating, I am happy to help out.

Can you share us if there is any error message on your end? Is it happening in the browser, desktop app or both?

Can you clear out the cache. Here are some information to troubleshoot: https://help.figma.com/hc/en-us/articles/360040523973-Troubleshooting-checklist 1

Also please try to force-quit and open Figma in a new browser window (or force-quit the Figma Desktop app and restart it.)

To get this troubleshooting process started, can you make us a short video? Please include the whole window, with the properties and layers panels in view and relevant layers expanded, and select any layers you’re having trouble with so we can check any relevant settings. We use these videos to try and reproduce the issue in our own files and so showing all steps needed to reproduce the behavior is helpful.

Please also share your file link here or with me via DM with support-share@figma.com invited directly as an editor (this won’t affect your billing at all).

Thank you in advance!

I also have this issue and it’s really cramping my style and my workflow - I’d love to see this resolved ASAP. I am going to update Chrome which might help, but a fix would be really useful. Thanks

Hey @Sheila_Sitaram, I understand that this issue is frustrating! Please let me know if updating your browser resolves the issue. Also please check if you have Chrome on the default configuration. Please also make sure you have the newest version of the operating system.

I can’t experience this in on my end, so I’d need a screen recording and further information to forward to the team to investigate further.

Thanks in advance!

I found a way to fix it. In “Mouse”, at “Double-click”, don’t drag the slider all the way , decrease it one notch and return to the left.
Just drag the slider full , and your Macbook will automatically disable the double-click feature to select objects or select text in all apps or elsewhere .
I’m using Sonoma version 14.4.1.

1 Like