Bug: Unable to 'Undo'

On the web version of Figma, I’m unable to use the ‘Undo’ feature - whether it be through the keyboard shortcut, or into Edit > Undo. Neither work.

Hey Tina, I’d like to get a bit more context to help troubleshoot, can you let me know a bit more about the problem you’re having?

  1. Is this also happening in the desktop app?
  2. Can you check and confirm if you see the same problem in any other browsers you have on your computer? Our supported browsers are Chrome, Firefox, Safari and Edge.
  3. Can you check the keyboard layout you have set as outlined int he article here? You can do this by selecting “?” in the bottom right corner of a open file > Select Keyboard shortcuts > Layout
  4. Do you have any browser extensions enabled?
1 Like

It’s not happening on the desktop for me, however a colleague has just flagged that he’s the opposite (ie. it’s happening on his desktop, but not the web version). I have the same problems in all browsers. The keyboard layout is correct, and the issue still persists when going to Edit > Undo in the menu system too.

No browser systems enabled.

*No browser extensions enabled

Thanks for confirming. I’ve just created a support ticket on your behalf, so our technical quality team can help you out. Your ticker number is #847776, for reference.

I have the same issue, alreaedy in the past couple of weeks, undo is not working. Not via shortcuts and not via the menu.

It does not work in the desktop app, and neither in the browser.

Hello, can anyone respond…?

have the same bug on web browser version. it’s frustrating that I cannot undo (neither by keyboard shortcut nor by literally clicking on the Undo selection under Edit.

Undo works on the desktop app though.

Same issue here but on desktop app. Tried clearing the cache and uninstalling the app but still no good. When I exit the app it’s fine for a bit but then after 5 mins the undo function stops working.

Hi all,

I shared this issue with our internal team, and they are investigating it. There is a new topic here but I will post when I have any updates I can share with you.

Thanks,
Toku

I just experienced this issue myself.

I right-clicked on a ellipse layer inside a group inside a group inside a variant of a component and selected “Flatten”. I wanted to undo because the layer disappeared but couldn’t. But could be a bug with Flatten not Undo?

I’m able to replicate this issue in both browser and desktop Figma (Win10).

I have a similar bug on the Windows desktop version of Figma. I imported a component from a library and shortly after that the undo function stops working. Not only does the shortcut doesn’t do anything, even If I manually select the action in the Edit > Undo menu it will not work.

Hi all,

Thanks for flagging. Our engineering team has trouble finding a repro for this issue. If you constantly see this issue, could you share the file link please? Please add support-share@figma.com in your file so our team can investigate it. it won’t affect your billing!

Thank you in advance.
Toku