Figma Support Forum

Bug: Problem with typing in Korean (Hangul)

This definitely is a bug and I would encourage you all to report it to Figma support team via the bug report form. They don’t often check the forum.

which font are you using? Does the same issue occur when you’re using Inter font?

I am also having the same problem - I have restared the Figma, deleted a main language as Korean and add them back in at Settings - pls fix this issue as soon as possible

Inter doesn’t support Korean. One of the fonts that supports it is Noto Sans KR.

yep thats correct. For fonts that do not support hangul, figma falls back to other font. i wanted to test if it was an issue with a specifc font or if it was an issue with the fallback font. I am unfortunately unable to reproduce the issue so far

Good call! The fallback font is Noto Sans, and it may work slightly differently on different systems (some people have it installed locally for example). Also as far as I understand, this issue is only present while typing (not in pasted text) and only in the desktop app, so I don’t think the issue is related to fonts, but rather to the input method.

I also have the same problem

1 Like

Please let us know what browser/environment you are seeing this in – I could reproduce on M1 macOS Monterey Chrome 96.0.4664.93 but when I upgraded to 96.0.4664.110 it was fixed. I could reproduce for a while on the Desktop app, but if I type a very long string into a text box it starts working again.

This issue also continues to happen to me. This issue does not occur on my Intel Mac or my Windows laptop. Its only happening on my M1 Mac desktop app (MacOS updated to the latest version Monterey).

I just fixed this issue on my computer. I hope it can be solved in the same way for others.

I realized that I could not find Noto Sans CJK KR font on Figma client, so I re-downloaded Noto Sans Korean from Google Fonts and now it works properly as expected. (Google Fonts)

After font install, I restarted Figma desktop client and it works well now.

Noto Sans Korean used to be called Noto Sans CJK KR, but the name is now changed to Noto Sans Korean by Google. Maybe this whole issue has something to do with this. Maybe something to do with fallback font not being recognized properly or not loading from OS system due to naming issue…

3 Likes

PLEASE!!! :sob:
I still have a this problems too!

1 Like

I don’t know why, but quite a few people reported me the solution :thinking: Try typing words really fast like… 니아럼니ㅏㅓㄹ히만아ㅣㅁ덯, then problem solved :exploding_head:

한국말로 고통받고 계신 분들 엄청 빠르게 타이핑 해 보세요~ 많은 경우 해결되는 것 같습니다.

2 Likes

When will this be able to be solved?
Many Koreans in the community ask dozens of questions about this issue.

도움… help!

same problem again…

Last year, i had this issue. However, It seems fixed and i use the Figma with no problem. But suddenly this issue occurs again from a few days ago. I did check the update, off and on my computer. But it doesn’t work.
Please fix it :pray:

I still have problem with typing Korean…and I’m facing new issue that I can’t see some Korean words after few hours in design which I already typed. I can only see when I click the text boxes, but the real problem is, when I share the design, other people also have to click every single text boxes. Please help…