Bug in the component sysem

Hi.
Since few weeks, I’m facing a really annoying bug in the components system.

  1. I created a cell item component. There are around 40 different variants depending on the size of the cell (small/wide) and its content (text 1 line, text 2 lines, image, icon, checkbox, and so on).
  2. Then, I created a list item component which is a list of cell item instances, ordered in line to make…a list item. This component is made of 9 instances of the cell component.

All of this is exported in the library I use in all the projects.

The bug is the following:

  • I create an instance of the list item object, to create a list specific to my need
  • then, I select a cell instance of the list item instance and I change the variant
    The bug is instead of changing the variant of the selected cell only, Figma changes the variant of all cells.

This has worked flawlessly for months. And since few weeks it doesn’t, as explained here above.

The workaround I’ve found is to create a list item instance, and detach the instance. And then, I can change the cells instances without problem. But it’s far from being perfect.

Any help or a fix would be great. Thx.

As eveything is better with an example, I’ve taken a moment to extract the necessary elements to reproduce the problem.

To reproduce:

  1. Create an instance of the list component
  2. In this list instance, try to change the variant of a cell
    TADA! All cells have seen their variant changed as well.

If I move the default variant off the list component (which is similar to remove the variant and properties which exist in my real design system), the problem is gone.

image

open your file to copying

Ok, I don’t see how to do this. Figma tells me to move the move in a project. I did this, but I still can’t give you the rights to edit. Pretty cryptic to me.

I posted those files in starter, free, plan. Does this mean I can’t share for edition?

Hello @romuald

You can only give edit access to others if your file is located under projects and not in Draft.

On Drafts people can access your file in view mode only

Thanks, I’ve put them in a project :wink:

That’s wrong info, you don’t need to move it. You only need to change the checkmark:

Hi there, I only read his comment, which he wanted to give edit access, Didn’t check yours which wanted copy, share …
by saying starter plan the err message looked like that the file was in draft.

to my knowledge starters in draft can give only view access

Screenshot 2022-11-14 154948

Got it, in this case I misunderstood your intention.

I’m not asking for edit access, I’m asking for the ability to duplicate the file so I can edit it in my own drafts.

1 Like

Thanks, Sorry for inconvenient. your so famous here and when I saw your name, I just read his comment and assumed the situation.

I should have read previous comments as well

Have a great day

Got it, but no way to dot it as the settings button doesn’t appear.

Haha this is so convoluted… Restricting copying access is a paid feature, so you can’t do it in a free team. If you move the file back to where it was created (your Professional/Education team), you should see the checkmark.

Oh I checked seems that option is also restricted for starter plans

Figma is playing mind games

No problem. I’ll do this in my pro account and post here the same files with proper shared access.

The design system : https://www.figma.com/file/fVVgfkLL5gXzues6mgqNZ3/rods?node-id=4267%3A52307

The test file: https://www.figma.com/file/fVVgfkLL5gXzues6mgqNZ3/rods?node-id=4267%3A52307

Both files are closed from access by link. :skull:

Ok thanks. I give up.Too much time consumed on this. I’ll see with the support.