Figma Support Forum

Why do some of my libraries not show up in "Enable libraries for all team files"

Our Design System is made up of various libraries. We want to enable most of these libraries for all team files by default.

However, only one of these libraries is actually showing up as an option under “Enable libraries for all teams”, despite the fact that all of these libraries are published and accessible via the assets panel.

1 Like

I have the same problem, looking forward for an answer

I think I might have come to a solution. At least it worked for me.

Double check if your Libraries Sharing Options are matching. When you set your sharing options for your library in your design system, make sure [“Anyone at YOUR ORG NAME” can view] is the option selected. If by any chance, your files have [“Anyone at YOUR ORG NAME with the link” can view] that might be the cause the libs aren’t showing up in other teams assets menus.

If you still want to keep your sharing options with [“Anyone at YOUR ORG NAME with the link - can view”] I think that only people who have accessed the library through a sharing link will then start to see it under their asset menu. But this second part is a guess.

1 Like

Thank you so much @Ito !
I can’t believe I had 3 e-mail exchanges with 2 separate Figma support people and neither of them mentioned this at all :man_facepalming:

1 Like