When I create a new frame, the number in the layer name is high (4M+)

Driving me coconuts!

When I create a new frame, the frame will be automatically named “Frame 48095626” How do I reset the latter number to 0 or 1?

This happens when I create shapes, the layer will be called “Oval 109384” or “Rectangle 12341239”

I’ve tried checking and unchecking file>preferences> renaming duplicated layers.

There is no way to disable this behavior. You just need to bring your file back to order by removing all large numbers from all frames or other objects or renaming them to a sensible number. This plugin can help with the former: