Variables from published library aren't available in the new project

Hello there. Shortly problem is that published variables are not available in the file where i enabled this library.

Steps:

  1. Published a library with two color variables (and two color modes)
  2. Enabled library in empty project
  3. Made a rectangle and tried to apply a variable

Results:
On first iteration i was able to apply a variable on rectangle. When i’m trying to change it, it doesn’t show the second variable.

On second iteration (the same steps) it went well and i don’t know why. I am able to switch between variables.

On third iteration i’ve tried to publish big library with 238 variables. In project file 0 variables appeared.


I have files from each iteration, so Figma support guys, you are welcome to investigate it.

2 Likes

Similar issue

The same problem. It is not clear how to publish variables.

Hi there!
Sorry to hear you are having issues publishing your library.
To cover some basics, here’s a guide how to publish individual styles, components, or variables: https://help.figma.com/hc/en-us/articles/360025508373-Publish-a-library#individual
If you are still running into issues, I’d recommend you to reach out directly the support with a copy of your file (where the library is located) and share a quick screenshot / video recording when the issue happens here: https://help.figma.com/hc/en-us/requests/new. This will help our team to investigate and replicate it. Thank you!

Problem solved. The issue was in variables with state “Hide from publishing”, a lot of them have been disabled in imported library from “Untitled UI” by unknown reason.

1 Like

Glad you’ve found a fix. Thanks for letting us know!