"Undo" doesn't work in Safari

Hello. When I try to undo previous actions I use command+z. In Chrome Edge and other browsers it’s okay. But in Safari it doesn’t work. Does anybody know how to fix it?

Hi there!
As a workaround, can you try to clear out your cache in your browser? Safari lets you choose which websites you want to delete data from. You can use this feature to remove data from just Figma: https://support.apple.com/guide/safari/manage-cookies-and-website-data-sfri11471/mac

Note: This will delete any offline changes and prevent you from saving them to Figma. Once you have cleared your browsing history, you will not be able to retrieve any unsaved changes.

Also, can you please make sure that your Figma account keyboard layout setting is set to the same keyboard than your device? (For instance US QWERTY may map “Z” to a different key if you have the French AZERTY). Please toggling this setting (Preferences > Keyboard Layout, Select keyboard layout: https://help.figma.com/hc/en-us/articles/5665442977431-Select-keyboard-layout) to the same keyboard you used in your device. (example: US QWERTY) and please reloading Figma to see if that helps the Cmd + Z for you?

In Figma:

In Mac, in the top right (please disregard the French, as my laptop is setting in French)

Hope this works!

I’m experiencing something similar. I think it’s because Safari’s reserved ⌘Z is not allowing that keystroke to be read by Figma. I’m wondering if anyone else has found a workaround for the keystroke. In the meantime, I’m using the Edit > Undo menu manually but it’s not ideal.

@Coufu, command+Z working for text fields but not with other elements.

@Celine_Figma, I’ve restored my Mac to default settings recently but issue is still with me =(

Hey there! Hmm this looks weird, feel free to reach out directly to the support team here: https://help.figma.com/hc/en-us/requests/new Our technical team can investigate it further. Thank you!