There should be an option to prevent interaction overlap between layers above and behind

The gif below should be self-explanatory about the issue

Enregistrement d’écran, le 2023-09-27 à 13.33.04.2023-09-27 13_35_47

1 Like

I’m facing the exact same issue right now and can’t find a solution to it.

Must-have!

In your example, you could use the “open overlay” interaction.


(Sorry for the crude mockup)

Screenshot 2023-10-20 at 10.55.13

Mine opens On Click, but you can also have it open after a delay of 1ms on the frame.

The overlay option prevents any interaction with the original frame.

2 Likes

Indeed, it is a great solution for some use cases. But it remain an unwanted behaviour. I have multiple cases that comes in my mind to illustrate it ; for my screen capture, clicking on the three dots also open a menu that interact with the layers below.

I wonder if an overlay for absolutely everything is a great idea, especially since overlay positioning can be a little of a mess. I see these dropdown menus as variants than a link to an overlay.

Adding a simple checkbox to specify that we don’t want below interaction to interfere with a layer would be a good idea.

1 Like

Oh, agreed, it’s an issue I’ve come across as well. There’s a bug in Presentation/Prototype mode where, if you follow someone going through the prototype and they open an overlay, sometimes you won’t see them opening the overlay. So we sometimes build our prototypes without Overlays to avoid that issue.

1 Like

Regarding this issue, @Bauke_Schildt , submitting a bug to Figma may be not that intuitive, but once you are in the loop with them, they are quite proactive!n :slight_smile:

You’re right, I should submit that as a bug. :slight_smile: