Stop automatically adding FigmaAgent to Login Items

I don’t use Figma all the time, I don’t want it to run anything on startup.
It’s frustrating to manually remove Figma from Login Items, since it automatically adds itself there again.

It would be nice to have at least an option to disable it in settings, or even better - remove that functionality at all, since it’s not user friendly. I want control over what and when the apps do at my workstation.

P.S. If it’s needed for updates check - I’m more than okay to update on app start

18 Likes

FigmaAgent*

4 Likes

FigmaAgent allows Figma app and website to load your local fonts. Since there is no way to find out when you’ve opened a figma.com link in the browser, it runs all the time to make fonts available at all times. It’s a simple utility so it doesn’t use up much resources to run and doesn’t do any network requests or other unrelated activities.

4 Likes

Thanks for the explanation of the purpose of the FigmaAgent. It’s interesting to know.

However, I never use the website version for my everyday workflow. It means that there’s no sense in adding it to the login items for me.
Still, I do not have an option not to do that.

An app is launching smth/changing OS settings on my machine without my consent. It doesn’t matter how much resources it uses. It shouldn’t be the case.

8 Likes

I completely understand your frustration! I’ve encountered the same issue with Figma, and it can be quite annoying when an application keeps adding itself to the startup items without providing an option fully to disable it in the settings.

5 Likes

Stop this. Stop redoing it every update I get. I don’t want Figma to open at login and if I did, I would set it up my self. Just stop. This is annoying. I have to delete the Figma agent every time I get a new update.

13 Likes

Hey @Josh47, sorry for the frustration!

The FigmaAgent starts itself for font access & to allow you access to any Figma links without having to log in.

If you don’t need either of those, you can force quit Activity Monitor, remove System Preferences > Users & Groups > Login Items
Then, delete ~/Library/Application Support/Figma/FigmaAgent.app & /Applications/Figma.app/Contents/Library/FigmaAgent.app

If you’re still getting the FigmaAgent on restart then you might have corrupt .plist file. To remove this, try running a Spotlight search and delete system preferences plist from User library > Preferences > com.apple.systempreferences.plist

The file path should look like this:
/Users/Username/Library/Preferences/com.apple.systempreferences.plist

You might also want to delete the login plist if you have it
/Users/Username/Library/Preferences/com.apple.loginitems.plist

Alternatively, you can click on Go in your systems toolbar >Go to folder > and type in the path name (keep in mind Username should be replaced with your own).

Then restart your computer. These files will come back as new (without any corruption) and you should be able to completely remove the FigmaAgent service from login items without any issues.

1 Like

So, will I have to do this every time there is an update? I’ve already done this before.

1 Like

Yes, because Figma automatically reinstalls the login item when you upgrade Figma. The only existing workaround would be to uninstall the desktop app and use the web browser.

We changed the topic to Stop automatically adding Figma Agent to Login Items, and our team already has this logged as a feature request internally, so we recommend keeping an eye on our Release Notes where we’ll post all major updates.

3 Likes

Temporary Work Around

Copied from stack overflow. All credits to orginal author marcaux

removing FigmaAgent.app
  • rm -fr ~/Library/Application\ Support/Figma/FigmaAgent.app
creating a dummy file
  • touch ~/Library/Application\ Support/Figma/FigmaAgent.app
make the file undeletable
  • sudo chflags -R schg ~/Library/Application\ Support/Figma/FigmaAgent.app

Now Figma will not be able to override that file when it wants to update it.

Also the login item does not get created for me again after removal at this point.

9 Likes

The only issue with this (as far as I know) would be that you wouldn’t be able to use locally installed fonts in Figma as that’s what FigmaAgent is for.

Adobe should listen. Stop installing and loading the figma agent at login. It makes my imac slow and the start takes forever.

Solution: just load the fonts when Figma app starts, or put a button to “update / refresh fonts” inside the app.

I will uninstall the app and use the browser until you fix this.

5 Likes

Still an issue. Still super annoying. Please fix.

5 Likes

Since there is no way to find out when you’ve opened a figma.com link in the browser

There is a great way: wait until I tell you. There’s no reason to install startup items without user permission and a built-in method to disable it.

The desktop app can/should only run this service when it is running and the stand-alone font service should have the option to only run when users wish it to.

7 Likes

Incredibly frustrating, please fix

1 Like

Annoying and robbing your customers of the ability to manage which apps open at login. That’s more than just frustrating.

Since this has been logged as a “Feature request”, I’m willing to bet that this was a deliberate choice by Adobe.

With that said, I’m uninstalling the app until it gets fixed. As an infrequent user of Figma, it’s just not worth the frustration. Please let me know once this has been fixed.

1 Like

I deleted Figma.app for that matter.

this is ridiculous. I am done with this. Jesus.

1 Like

This is so frustrating and feels like something adobe would do, not the wonderful teams at Figma. First instance where i feel you’re becoming Adobe. Please please please fix asap please. It’s so bad you have no idea

I am shocked that you have the audacity to tell us that we have to manually go through these steps just to remove the virus that you install on my machine.

This just tells us that you are inconsiderate towards your users needs and do selfish things just to benefit you. Bad Figma! I will be switching if there is an alternative.