Figma Support Forum

Setting to turn off automated lists

Does anyone know how to turn off Figma’s auto-formatting? I’m trying to type '- ', but it looks like Figma is assuming this text must be a bulleted list.

I’m having a similar issue when using text that’s in the format of an email address or a url. Figma is changing these to unwanted links. I’d like to turn off all text auto-formatting.

1 Like

There is no option to do that so I changed your topic to a suggestion people can vote for.

The only way is to press Cmd/Ctrl + Z to undo the list creation once it is created automatically.

A preference to disable this would be great. Perhaps a better feature would be the ability to choose which of the default characters will create a list (or set your own), so that you can either disable it entirely or just disable certain problematic character combinations.

A couple additional pain points this might solve:

  • Using any of the creation characters at the start of an already-converted list item will cause the character to disappear.
  • Using characters for the opposite list type automatically toggles the list type. (side note: there is some convenience to mixing lists on the fly, but maybe this is only necessary in nested lists, since you’d rarely mix lists on the same level)
  • Toggling a list style off removes any typed characters that were automatically converted to list markers. It feels like a bug that you’d lose content when toggling a style property, but I found it noted here too. Unless this changes, disabling some characters from creating lists would be a fine workaround that wouldn’t require you to quickly hit cmd+z before you get too far into typing.
  • This probably isn’t a widespread issue, but the auto-lists do make it somewhat frustrating to work with content that includes asterisks (footnotes/disclaimers) and with code snippets in languages that use the same syntax (YAML, Markdown, etc). Turning off those shared characters would solve this.
1 Like