Figma Support Forum

Scrollable vertical is disabled for instances?

Here is a video explaining my struggle :point_down:

Can we have another checkbox to enable and disable fixed positioning for overlays?

Here is a sample in Bootstrap: :point_down:

Hey @Hossein_Boroji

Would something like this work, if you set vertical scrolling on the entire frame that the modal content is in? You can use the manual setting for the overlay if you need it to be in a specific area. Here is an example:

1 Like

How did you manage to give your modal vertical scrolling ? @Tom_Lowry Mine is disabled :point_down:

Would you mind helping me out with this problem ? @Josh

Have you by any chance found out why it is disabled and grayed out when it comes to instances ? @Tom_Lowry

Hey @Hossein_Boroji I believe two things have to happen. First: scrolling needs to be enabled in the Main Component (it is not an overrideable property within an instance). Second: the frame needs to be smaller than the content in the direction you are planning to scroll, otherwise you will get a little warning when you set the scroll behavior. Hope this helps!!

1 Like

Hey @Tom_Lowry OMG you were right on spot. I didn’t know I had to enable it in the main component. I also reduced the frame size to get rid of the error message :dancer:

Thank you so much again :heart_eyes:

I don’t know how to mark this ticket as solved, otherwise I would have right now.

@Hossein_Boroji so happy you got it all working!!!

1 Like