Figma Support Forum

Resolve conflicts doesn't do anything, can't merge

I’m trying to merge changes back from a branch and I’m being prompted to resolve conflicts first. However when I hit “Resolve conflicts”, the dialog just closes and nothing happens. If I try again, I get the same screen with the same message so I’m unable to merge anything. Is this a known issue?

Hi James,

Sorry for the inconvenience! This may be related to a known issue—are you working on a branch which has been restored since a merge into main? If so, we are looking into the issue, and must recommend that you work on a new branch.

If not, I will follow up with you privately to learn more! Thanks for holding tight!

Has this issue solved yet? I’m struggling same issue now.

Hi! Is it resolve? I’ve the same issue now, thank you!

1 Like

Same issue here, pressed resolve and am taken to library without my changes and then it applies them 30-1m later but has no conflicts. After I did this once the number of conflicts actually went up from 1 to 2.

My original issue seemed to resolve itself after being stuck for a 3-4 weeks, but I didn’t do anything in particular to fix it. Not sure what happened!

I have a similar issue when trying to resolve conflicts. The progress bar gets to the end and then just sits there. I have to restart Figma to get out of it.

I have this kind of issue too. Despite several update of Figma. Each time the update couldn’t be done because of a conflict I couldn’t resolve. When I tried to update the branch from master or resolve the conflict I got a grey full screen. Sounded like a great old windows blue screen :smiley:

The same problem as Jean, there is a console error: