Prototype resetting Scroll Position

The problem is still relevant. Can I find out if there will be a fix?
Continuing the discussion from Prototype resetting Scroll Position even though those settings have not been selected:

Have you followed these Help Center articles?

Yes, I read these articles. I have a problem with animation in components. When animating simple frames everything is fine. And when using an animated component, everything breaks. I can’t find the reason.

Could you share a link to the example file?

Here’s an example

Do I understand correctly that the bug occurs when collapsing/expanding chapters? If yes, then this is due to a bug in the smart animation of auto layout frames. There are two solutions here:

  1. Instead of “Smart animate”, use “Instant”.
  2. Wrap your auto layout in a frame of a fixed height (set the height equal to the height of the device), and also change the overflow scrolling behavior (from “No scrolling” to “Vertical”) of this frame.

The second option worked! Thank you very much!