Figma Support Forum

Most interactive components randomly stop working

This is the second time this has happened to me.

I have spent a ton of time updating my variant components to work in my prototype. Mostly mouse over interactions. I test like crazy as I am building. I test in the component library files and I test in a copy of one of our prototypes. While I am building things are working great. Later in the day, I restart Figma, then go back to the same prototype, and just about all of the interactive components stop working.

I have tried opening up the prototype up in both the desktop (Mac) and the web version of Figma but neither are working.

I tried several restarts and reloading of the prototype but nothing work. Now one thing I did notice, one of my co-workers was in the prototype. After he left all the interactive components started to work again with one exception. All the components that include images (i.e. avatars), the images are not showing up.

Anyone else experiencing this or similar issues?

I’m not sure if this is related, but the interactive components “Playground” project doesn’t work at all for me (I confirmed the checkbox is enabled). If I create an interactive component in a new file, it works fine, but they don’t work at all in the playground file for me.

Same here - interactive components stopped working. @Christian - were you able to fix it or know of any ways to debug this?

Same problem, sometimes it works, sometimes not

1 Like

Same here, it seems that most of the more complex stuff doesn’t work properly, like autosize or nested components etc. Interactive components are very useful if we can build menus with autosize and reuse trough libraries and nesting components.

Hi all! I’m an engineer on the prototyping team. Thanks for flagging these issues.

@Harun_Alikadic1 - we don’t have full autolayout support yet, but we’re working on it!

@Christian this sounds like a major bug. Do you mind sharing the file with me via DM?

I think it had something to do with other people on my team that were in the file(s), that were not yet invited to the beta.

To support my suspicion, when I was the only one in the file it started to work again. Also once my team mate was invited to the beta it also started to work with him in the file.

I hope this helps.

Parent and nested components interaction conflicts, if both have interactive components

I’ve experienced similar problem. I’ve added interactions in my variants and in prototype mode it sometimes works properly but sometimes e.g. buttons on hover seem to be losing their padding.

1 Like

Similar Problem. I have a nested component, for example button. Master component has interactive states (hover, pressed), and child component has different variants (with/without icon, etc.) Sometimes all interactive components stop working and randomly recover. Same situation in other components with similar structure. When interaction works, i see slight change in button padding first time I hover it.

Again I am experiencing the problem of images not showing up in my prototype. I read in an unrelated Figma help document (regular support) that sometimes images won’t show in prototypes when you have slow internet speeds. My average speed is between 185Mbps and 265Mbps which should be plenty fast. Also, this time when I closed all my Figma files and did a full quit/restart then ran the prototype the images came back.

And again!

This problem is very random. Today again the images are not showing up. I included a screenshot of the prototype missing the images. And just for context I also included my internet speed at the time of this occurrence.


To fix the problem (for now) I had to close all tabs, then quit and restart.


The same img as above when it is working (post restart).

Has something happened recently? Literally, all of my Figma interactive components have stopped working properly.

+1 In the prototype, when hovering over any component with the “While hovering” effect, the entire prototype freezes and no longer works.
Even restarting the prototype doesn’t work. :scream: