Invalid component / unused properties in update

Hello everyone,

When trying to update components from library I get this message. I don’t know what it means or why it’s appearing.

Anyone has any idea how to solve this, please?
Screenshot 2022-06-06 at 12.54.00

4 Likes

Difficult to say without having access to the file. But maybe you have conflicting properties between variants of the dropdown component. Figma itself will warn you this on the sidebar when selecting the master component. Try it out and see if it helps.

2 Likes

Hello Vinicius, thank you for your reply.

I can’t find any component that has conflicting properties :\ neither here on on the left panel of the component. Any other idea?

2 Likes

Hmm can you screenshot the sidebar with this dropdown component selected? Sharing access to the file would also be great if possible

1 Like

I cannot share access to file due to company policy, but once I read your reply I looked at the file again and there it was. The warning icon on each property (last three ) went completely unnoticed and I was getting really stressed out. Once I removed these properties everything went back to normal.

Maybe figma should think of updating these warning icons so they’re easily noticeable?

Screenshot 2022-06-07 at 10.06.44

Thank you for your help Vinicius

13 Likes

Ahh this has been driving me crazy haha. Thanks so much @Barbara_Araujo and @Vinicius_Blembeel :pray:

Crazy that components can’t be published in a library if there are unused properties :grimacing:

3 Likes

OMG, Thank you for shared how you solved this problem.:sob::sob::sob::sob:
Finally I solved this problem!!

1 Like

Thanks, it helped me a lot!!!

Thank you, the suggested answer works great! To reiterate, when looking at the variant properties, look for the (i) icon that will indicate which property is going unused. Tap the minus button next to the unused property to remove it. You should be able to publish the component just fine now.

4 Likes

I am having the same problem now, but I am not seeing the warning (circle-i) icons beside any of the component properties.

1 Like

Helped me a lot - was befuddled by the failure to publish a library - your solution worked first time. Thank you to everyone who chipped in !

2 Likes

Oh lawwwwwwdd… thank you guys!! :heart:

2 Likes