Interactive components stop working when using smart animate

Hi, everyone.

I’ve been noticing an apparent issue with interactive components that stop working when used in variant components. And it’s also breaking (freezing) navigation between flows in prototype view.
I realized that this bug is occurring only with ‘smart animate’. When I change to ‘Dissolve’ or ‘Instant’ it works normally.
I think this is probably a bug or an issue, because I have worked on these same components a few weeks ago and it was just fine.

P.S.: I noticed this after I updated my desktop app to version 107.0

5 Likes

Yeah! This happened to me too!

same problem here!

Whoa! Nice find @Teilor_Capanema. I thought I was going crazy.

1 Like

Had some similar problems and created a ticket. But after some investigation I also conclude that something gets wrong with smart animate.

1 Like

I have an interactive component that simulates removing an item on click (changes width of an auto layout item to 0.001). If I set the animation to smart animate on that change, it kills the whole prototype, even hitting refresh won’t reset it. However if the change animation is set to dissolve or instant it works as expected.

Here is a link to the test prototype.

I had similar problem too.

same here!
found this post :

all but smart animate works… is there a fix or workaround?

1 Like

Hi, Eve.
In cases where I found issues, I used ‘Dissolve’ and it works.

Yes, It works! After 2 months of not understanding why.
Now that I found that solution… Just makes my prototypes less pretty…
Hope it will be solved :slight_smile:

1 Like

I am pretty certain that smart animate was working in my prototype with auto-layout and interactive components. But today it started giving me problems, hope this gets fixed. Using dissolve for now.

1 Like

Yeah. For me it was the same. I builded once and all it works normally after tests. And after version 107.0 the problems have started. Dissolve was very helpfull.

1 Like

I’m also experiencing this issue since the last update in the mac app, it also breaks the rest of the prototype, nothing else is clickable if I click on an interactive component that has a smart animate interaction in it… instant and dissolve work properly but still a shame cause that smart animate is nice!

1 Like

Yeah, it freezes and breaks all prototype for me too.
I thought this just happened when I had components with other components inside. But it occurs with simple components as well. And the real reason I don’t know why.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.