Figma Support Forum

Getting "no changes to merge" in "Review changes" after making changes in a branch

I created a branch of an icons file, and updated two icon components in the branch. When I select “Review and Merge changes” it says “no changes to merge”.

I archived & deleted the branch, and tried again with the same result.

I also received this same error. Made a branch, updated the effect style for numerous variants of a component and it said there were no changes to merge.

Hi,

Sorry to hear that - Brian, can you share the kind of changes you’re making? Emily/Brian, feel free to DM me with more details / the URL of the file, so that our team can investigate further.

Thanks!

  • R.J.

@raquino this is what happens when I create a branch of a published library file, make a change, and then try to review and merge changes. (DMed you a link to the file)

Branching library file screen recording

Hello, we have deployed a fix for this issue. You may need to refresh your tab. Please let me know if you are still seeing it - thanks!