Frames are not showing full width on prototype

img 1: shows the frame at full width

img2: shows the prototype but not the full width of frame


@Emmy On the prototype options panel, try setting it to “Fit width” to see if that helps. But that will not make your design fill your browser screen until you start scaling down your browser width to be the same or less than your design’s frame width in Figma.

Hello, I have the same problem; however, it’s the opposite. I created a visual, and when I export it to HTML for my developer colleague, it doesn’t fit 100%. He has a scroll bar that appears. We made sure that his browser is smaller than my design’s frame.

Also @Nate_G I can’t find “options > fit width” as you screen

Thank you in advance for your help.
Snipaste_2023-10-06_09-38-31

The prototype Options panel is available when you are in “Present” mode.

Thank you for the indication. However I don’t have the same option than you. What can I do ?

Click on the Options dropdown to get access to your prototype view settings, and set it to “fit width” to see if that helps.

Sorry I sent the wrong screenshot. As you can see, I don’t have the “fit width” option
Snipaste_2023-10-16_09-08-41

@ev_tvt Ah ok, correct you can’t get access to that option if you are displaying your prototype on a device, but if you set your device to “None” then the “Fit width” option will appear during prototype mode. But not sure this will fix your original issue.

2 Likes

Hello, it worked, thank you !

1 Like

I am having the same problem, I have tried fit width and everything I have come across but anytime I go to preview mode or present, it does not fill the entire screen. I have tried everything

Hi there,

Thanks for the post. Could you double check the scale section in this article? If it doesn’t solve the issue, would you be able to share the screenshots you’re seeing?

Thanks,
Toku

I have tried it all but still nothing. okay will send some screenshsots. what exactly do you want to see so I screenshot it and send it. screenshot when i go into preview mode?

Thank you. Screenshots for the preview and present would be helpful.


@Bright_Baiden Thanks for your screenshots! As I checked them, it looks no problem. Could you reach out directly to the support team with a copy of your file: https://help.figma.com/hc/en-us/requests/new. They will give you further support. My apology that I can’t help much here.

Please make sure you use the email associated with your Figma account, include links to the file in question, and share access with support-share@figma.com. Don’t worry, inviting us to view your file won’t impact your billing.

Thanks,
Toku

Love that you posted this fix! It was a headache trying to get fit width back. Thank you.

However…this just proves how problematic Figma’s lack of understanding UX is! Why can I not demo to a client with the device frame where my prototype fills the device frame?

To me this is a huge fail. Thanks Figma.