Font changes by double clicking and copy-paste

Hello everyone,

I created a component library for my company. In this library, when i click on components or copy-paste this compınents to another page, font changes and i need to change is manually after. With font replacer plugin, i solved this issue however this is a temporary solution. By the way, changed fonts are not a font in my computer.

Can you help me?


I was faced with this glitch, too. But I couldn’t resolve it yet.

@Atakan, @Fsevgili, try to correct the text with the command “Recompute text layout in selection”. Alternatively, you can use the “Regenerate all instances (slow)” command. To do this, you need to open the “Quick action” (search engine in the file) and start typing these commands.

1 Like

Unfortunately bro, it didn’t work

Same problem here. It’s a real concern because we have hundreds of pages, we are maybe 10 or 12 to work on it and it seems that some people just need to touch an object to change the font to something else…


I am facing the same issue with the fonts.

Facing the same issue.

Hi! i’m an engineer from Figma and just found this thread. i’m investigating this issue.

It’s possible this is an actual bug fix where previously the font metrics were read wrong and it’s not displaying correct.

If anyone has the time I’d love for you to use the font you’re using and

  1. create a simple HTML page that uses that font with the same font size/weight.
  2. With that page zoomed at 100%, highlight that text and screenshot it
  3. paste that screenshot into a Figma file
  4. create a text node in Figma using that font and overlay it ontop of that screenshot

Please let me know if they do or do not line up and which font you’re using.

My hope is that the new text is actually more representative of the font file and is how browsers would actually render when using that font.

My issue is that it’s simply not the same font I updated it to in the component library. The library font is not pulling through to all instances. And it’s not because I edited the font in the instance before updating the library, I checked…

Hi everyone.

I have been facing the same problem in my work, so making a little research, I have noticed that it doesn´t happen when you are working in the browser version.

Hope it helps

So there is still no fix for this bug? Radio silence?

1 Like

I’ve just done an update on my font styles and in some places, the changes are reflected, but other places not. Very weird, and only fixable if I double click on the text.

@Delong_Fu Any update on this?

FYI, I got curious, since I user Themer to update styles to different themes.

A workaround is if you re-apply the theme to the frames - this seems to force the fonts to reflect the style. At least this way you can get all styles to reflect correctly in one operation, instead of having to click all over the place.

im not familiar with Themer and how it changes your fonts.

For everyone encountering this issue, what font was used in the component and what font do you see in the instance?

I have the same issue. After double clicking on an instance of a component, Gotham Medium starts displaying as italic for me and three other people working in the file. It had been fine for weeks until the 4th person joined the team this week. I suspect that she may have had an older version of the font installed and somehow that affected it?

I was trying to use the fix of selecting all with that font and then applying “Recompute Text Layout in Selection” – except I can’t find that option anywhere!!!

Help, it’s infecting all of our designs!

1 Like

Yes, it could have had an effect. All editors on a team must have the same font versions installed.

1 Like

I am facing the same issue. The moment I double click some text, it changes it’s position. It is very annoying to see as I manually have to change fonts placement on all the artboards. Hopefully this issue gets fixed soon.

Hi, I’m struggling with the same issue. I have a font with specific font weight and font size in the design system which isn’t syncing to other files. The same font in other font sizes and font weights all pull through to other files from the library. It’s very painful to have to detach the component and then update this font style manually.

I’m happy to walk through this issue with a programmer in Figma to debug the issue since it’s causing a lot of friction in my daily work.

This is still happening to us.

We have a branch from the main design system and all fonts were broken, so by using this solution of the quick actions + “Recompute Text Layout in Selection” on all selected layers it worked for us.

Easy to fix, but honestly don’t see the why behind this bug.

Same issue here.

We’ve recently updated the font connected to our library, and after publishing it, we don’t see the font changes reflected in some of the components, until we double click / edit the text. (its arbitrary as far as I understand it).

Any updates?