Figma Variables Messing up Prototypes?

Hi, I’ve been using Figma to design our company’s application for over 5 years now and was prototyping using the traditional method of using spaghetti lines and gazillion frames to present a feature, so when I discovered their recent release about variables, I was excited to try it out and implement it for our team to be more efficient in making prototypes with lesser frames at a lesser amount of time.

I’ve had no problems using variables in my early stages of designing for our product so far, until this particular instance:

The process flow for this is as follows:

  1. Click the first item (tagged “Console”)
  2. Transfer through each tabs available on the modal (this is made using variables, see attached pictures)

When presenting the prototype, the error happens on step #2, where you will experience stuttering of the prototype and a laggy response (about 5s).

Did I do something wrong with the prototype? Did I mess up with my variables or something? Or is this just Figma? Please let me know. Thanks!

1 Like

here is the configuration of tabs:

Hi there! Thanks for reaching out to the community.
Can you please share a quick video recording where the issue happened ("stuttering of the prototype and a laggy response -about 5s- ") to check if we can replicate on our end? I tried to navigate in the prototype tab, and it seems to work as it should on my end, but I may miss something.

Also, can you double check if the issue happened in browser, desktop app or both? As our first troubleshooting steps here, can you try to accept all pending updates (if any), then clearing out both your desktop apps and browser cache and see if there are any improvements?

You can clear the desktop app cache on a Mac in the Help menu under Troubleshooting. If you’d prefer to manually clear your cache, you can:

  1. Quit the Figma desktop app
  2. Open and enter the following command: rm -rf “$HOME/Library/Application Support/Figma”
  3. Try opening the desktop app again

You can clear the desktop app cache on Windows under the toggle-arrow at the right of the top toolbar under Help > Troubleshooting. If you’d prefer to manually clear your cache you can:

  1. Close the Figma desktop app
  2. Open the Start menu, and paste in this, followed by enter: %APPDATA%\Figma
  3. In the window that opens, delete the Desktop and DesktopProfile folders if they exist
  4. Launch the desktop app again

Hope this helps!

1 Like

Hi @Celine_Figma ! Thanks for this! I’ve tried it on the web browser and desktop app and both are showing the same issue. Here’s a Loom video of me explaining what I’m trying to achieve and it shows how I set up the variables and how the prototype seems to be broken or laggy (which now responds in about 24s or so):

I’ve tried clearing up the desktop app cache but it doesn’t seem to solve the problem for me. Please send help, thanks so much, really appreciate it! :sob: :sob:

Hey @CodeChum_UX_UI , thank you for the detail video recording!
Ohh, I can also now replicate, it’s also laggy on my end! (10 seconds when I clicked on “Test”, and “Used In” works perfectly)
From what I see, the root cause might be from your large file, that causes a slow performance. I’d recommend you first to try to reduce memory usage in your file, this guide shares some tips to solve it: here

If the issue still persists, please reach out directly to the support team: here The technical team can investigate further.
Please also make sure to use the email associated with your Figma account, including your video recording, a link to the file, and share the file with (with edit access), so they can take a closer look. Thank you!

Thanks @Celine_Figma ! Unfortunately, memory usage isn’t also the case on my end, as it currently displays only 3% for this page :smiling_face_with_tear:

I will try reaching out to them directly about this, and hopefully they can end my burden T_T thanks so much for your guidance!

I’m experiencing the same lag due to using variables & conditions. I was wondering if you had any luck?
Thanks, Dave

I can report that exact same behavior and same ~5second delay (minimum, sometimes longer). I got a bit over excited about how close I could make the prototype to a functioning app for some pages and hit this wall.

I was setting a bunch of variables on each click, but now even 1 creates the 5 second slow down. I am removing variables now to see if I can find a threshold or spot where it gets too bloated.

While big, my prototype is only 15% memory. It’s not available memory which leads me to believe it isn’t something users can fix.

I got the same issue in an onclick “change to” the transition was instant, but when adding setting variables in the same onclick the transition became laggy and delayed. (Each set variable seemed to add ~0.5s time to the delay)

Hey @CodeChum_UX_UI, our team is still waiting for a reply from you regarding getting access to your file on ticket #932908. Did you already self-solve your issue? If not, please check your inbox or possibly your spam folder, just in case it landed there by mistake.

For anyone else experiencing a similar issue, please reach out to our technical quality team directly via this form for help:

Be sure to use your Figma account email, include a link to the file, and share it with, so they can take a closer look.