Figma update - Prototyping issues

Hi all,

After the most recent update of Figma - Pushed a couple of days ago, prototypes using Figma’s nested component prototyping have been affected. This has been cross checked on web links / alternative machines.

This has new overwrites that aren’t included and are causing very concerning issues, especially on components that use auto layouts. This, ultimately, means if we hadn’t complete a round of user testing a couple of weeks prior we would have some serious issues.

Is anyone else getting anything similar?



I also noticed my nested components are not behaving as they should in prototyping. I have tested several times now and the nested component instances are continually reverting to their original component state.


I’m not alone with this shit


I’m having this same issue…nested component instances are not maintaining overrides and are always reverting to their original component state.


Same issue here. I have been trying to figure it out for a couple of hours and can’t find a workaround.

I found a workaround. If I rename the nested components to make them different between variants, then the nested components won’t revert back to their original state in the prototype. Hope I’m explaining that right. The bug stopped once I changed “Item 1” to “XXXX 1”.

1 Like

I have tried this at first… and it works once !
Is it still working on your side because for me after a figma restart and file relaunch
it was no more working, despite the renaming

Interesting! Will give this a try as well and report back

Do you guys have a problem with changing variants of nested components on tap in an iOS/iPad OS app? I mean, if I nest one component in another, then in prototype mode, that nested component doesn’t change its status on tap…

Hmm Im getting issues on web prototypes, but I haven’t looked into mobile prototypes, but can imagine they would be affected as well.

Same issue here, a real inconvenience.

1 Like

@Fred_Tinsel After restarting Figma and closing /reopening the file, it’s still woking for me. :man_shrugging:

1 Like

I was having issues with nested components too, which I only noticed after the update yesterday. My tab components nested in a group were not retaining text property overrides.

I found @Jason_Hlavenka’s solution to work for me—but I had to name each nested tab component something unique, even across variations of the high-level component. Feels really counter-intuitive but it’s a workaround for now.


I will not rename nested components
1- It will create trouble for swapping library
2- When it will be repaired, another issue will happen because of the renaming

Please @Figma_Support can you give me the address where to send the bill ?
for the time spend trying to understand, to hack… to explain to clients…


Glad I’m not the only one with this issue! This has been happening to me for a few days. I’d also tried renaming nested components, but that doesn’t always work for me. When I can, I remove non-imperative interactions from the nested components (ie hover, mouse down states), so my prototypes can be mostly functional. It’s incredibly frustrating.

This has been happening to some of my components as well. Overrides work fine when swapping variant states in the workspace, but once I go into the Prototype suddenly variants start having reversions to default states. It’s usually just the color but sometimes it’s the icons themselves reverting to whatever default icon is used in the base component.

Whats even more strange is that an icon color will revert to default on the first interaction in the prototype, but if you cycle between states more than once, THEN it changes to its correct colour.

I can’t figure out how to work around this since all my layer names and layer structures are indeed set up correctly yet prototypes still exhibit this strange behaviour.

Hey all - Must have been a pushed fix in the background over the weekend, seems to be fixed on my end, so might be worth a check

1 Like

I have the same issue, and it is not still resolved. Was it fixed with the weekend update for everybody else as well?

Hey all, if you’re still running into this issue would you mind reaching out directly to our support team? We’d love to dig into this a little further and see what might be happening. Thanks! :slight_smile:

Submit a bug form →

Yeah, seems to be fixed for me now. I’ve named everything back to how it was and it’s still working.