Export rounded corners, still showing up with grey/white border

I think Im loosing the plot! Im new to Figma and have been able to search and find help on everything but this. Exporting image, still showing up grey on the border. Ive tried the suggestions in the forum, making sure frame is transparent, exporting as PNG, and making sure elements are locked in frame and NADA.

This is the PNG export. TIA

can you show the original file or at least a screenshot of the original frame/layer structure/properties panel?

Sure! I couldnt work out how to do it in the post so I did in the comments. TIA

You just attached the same screenshot. Can you share the Figma file link? Or at least a screenshot of the full Figma window with the frame selected.

Share the Figma file link to analyze it.

I hope this works!

You need to turn on “Ignore overlapping layers” as you are exporting the frame with the Figma’s grey background. Looks like you disabled it by accident since it’s enabled by default.

Also please turn on “Snap to pixel grid”, your design is very messy because this setting is disabled.

Thanks! This worked! Gosh I wish I asked earlier!

Hey all, the easiest way I found was to literally just select your frame, “COPY AS PNG” then paste it wherever you need. I hope this helps!