Empty image when import Illustrator SVG pattern

When I import my SVG pattern created in Adobe Illustrator I get empty image:


This SVG freely opening in any browsers, Photoshop, and anywhere else, instead of Figma, what could be a problem with it?

Hey @Diversity ,
Sorry for the trouble! Is it happening in browser, desktop app or both?
Can you confirm what method you are using to do this - for example clicking and dragging from your desktop?
Usually, this can be fixed by clearing your cache in your browser and desktop app (if using this) and please, try accessing importing the SVG again?

You can clear the desktop app cache on a Mac in the Help menu under Troubleshooting. If you’d prefer to manually clear your cache you can:

  1. Quit the Figma desktop app
  2. Open Terminal.app and enter the following command: rm -rf "$HOME/Library/Application Support/Figma"
  3. Try opening the desktop app again

You can clear the desktop app cache on Windows under the toggle-arrow at the right of the top toolbar under Help > Troubleshooting. If you’d prefer to manually clear your cache you can:

  1. Close the Figma desktop app
  2. Open the Start menu, and paste in this, followed by enter: %APPDATA%\Figma
  3. In the window that opens, delete the Desktop and DesktopProfile folders if they exist
  4. Launch the desktop app again

If this does not work, please reach out directly to the support team: here
Be sure to use your Figma account email, include a recording showing what happens when you try to import the SVG, links to the file, and share it with support-share@figma.com so we can test it out on our end. Hope this helps!

Hi @Celine_Figma! Yes, dragging from desktop into app. This problem exist in both in web and desktop app. After cleaned cash this problem still exist. I will mesage to support team, thanks!

1 Like