Figma Support Forum

Disable auto-nesting/auto-reparenting while moving objects

  1. Describe the problem your experiencing and how your idea helps solve this

The issue with this feature has been covered many times in Spectrum discussions:

There is a way to avoid this by holding SPACE as soon as you click & don’t start dragging the object. But why force us to do acrobatics with our fingers by holding down an additional button, just to move the object? Why not provide an option to disable that functionality completely?

Nagaraj Chandran had a very logical idea in his comment:
“I don’t want to hold the spacebar key to disable auto-nesting. Maybe, it should be the other way around. Hold spacebar or any other key to auto-nest.

  1. Add as much context as possible (screenshots, Figma files, mockups, etc.)

More than enough in discussions on Spectrum :point_up:

  1. Ask questions to bring the community into the conversation

Does anybody find this feature useful? If yes, please enlighten me on how to make use of it because it’s driving me insane and kills my productivity big time.