Designs don't appear the same in Prototype mode


I was viewing my designs in prototype mode and I noticed they aren’t appearing the same as the original designs. Designs were made using frames for the MacBook Pro 16" and my prototype device was set to match the frames.

Prototype mode (Fit to screen):

I’ve tried viewing on other devices and the lines and some other elements appear to be weird and janky. I’m not sure if this is a resolution issue but it has become a problem when I want to record the prototype in motion. Would appreciate any help thanks!

Make sure your the zoom of your UI.
(ctrl+alt+shift+“+” or “-”)

I think i encountered a similar situation like you and it was due to the UI zooming.

I tried and it did nothing to the prototype design. :smiling_face_with_tear:

Mind to provide a proto llink?

Here you go →

These look like antialiasing artifacts. This is when the viewing zoom is different than 100% (originally designed). Since its on 1px lines this is unavoidable on a zoom different than 100%.
Try to remove the laptop overlay (since the person viewing will probably use a laptop to view it already), and set the viewing scale to “Actual size”.

Agree here.
The laptop overlay may be the cause.

Also check that green background you have on the column, as it is leaking through cells:

I tried it but lines are still janky, some even missing :smiling_face_with_tear:

Hi there – sorry for the trouble! GPUs have known bugs and may cause rendering glitches when using Figma. I also recommend you to check the Figma browser requirements here:

If this doesn’t help, please reach out to the support directly so they can have a deeper look at it:

1 Like