Create teams by workspace admin

Currently the setting ‘who can create teams’ can only be set to ‘anyone’ or ‘organization admins only’. I think team creation is something that can also be delegated to workspace admins. Is that something you can add?

Hi @Peter_Groenewegen, Thanks for reaching out about workspace admin! Yes, on the Enterprise plan, we have two options for who can create a team in an organization. If you choose “Admins only”, it includes organization and workspace admins.

  • Anyone: Any member of this organization can create teams
  • Admins only: Only organization and workspace admins can create teams

For detailed information, please refer here: Manage who can create a team in an organization

However, Thanks for pointing out that you’re seeing “organization admins only” instead of “Admins only.” Would you mind sharing screenshots or video recordings of the Admin > Settings > Team management > Creating teams? This will help us take a closer look into the matter.

Thanks so much for your assistance. Looking forward to hearing from you soon!
If anyone else encounters the same issue, feel free to reach out to us!

Thank you,

Hi @Junko3, Thanks, for this clarification. Maybe it’s a good idea to update the description in the admin settings, since now it reads’ ‘Only organization admins can create teams’.

Hi @Peter_Groenewegen, Thank you for your suggestion! I’ll make a request for you to our internal team.

While testing it on our end, I haven’t been able to reproduce the same screen display yet. Just to confirm, is the red circle in the image below saying “Organization admins only” and “Only organization admins can create teams”?


It would be incredibly helpful if you could share a screenshot so our team can take a closer look!

Thank you so much for your assistance!

hi @Junko3, Here’s a screenshot of our screen. We are on Figma Enterprise. However, I do not see the text you have in your screen. That would indeed be much more clear.

Hello @Peter_Groenewegen! Big Thanks for sharing the screenshot and providing the details! I completely get where you’re coming from regarding the wording. I’ll make sure to bring this up internally.

Once again, appreciate your help! If you have any more questions or need further assistance, feel free to reach out to our community!

Hello @Peter_Groenewegen it’s me again! As we delve into this issue internally, a question has come up to clarify whether this behavior is expected.

  • Could you please double check if your Organization has set up Workspaces and assigned Workspace Admins?

If your organization has completed these steps above, the wording in this modal might be a bug. For your convenience, you can refer to this guide: Launch workspaces in your organization

In such a case, would you mind reaching out to our support team directly through this link?: https://help.figma.com/hc/en-us/requests/new?ticket_form_id=360001744374
Please make sure to use your Figma account email, attach the screenshot you provided here, and mention that your organization has already set up workspaces with assigned workspace admins.

Thank you for your understanding.
Feel free to reach out if you have any more questions or concerns. Our community is ready to assist you!

Yes, we have setup workspaces and assigned admins to those workspaces. (This is even required to create a workspace). However, the current admins are also all organization admins.

Since you asked this question, I’ve now also created a workspace admin that is not a organization admin. But this has not changed the wording of the settings text for ‘who can create teams’. I’ve also restarted Figma and logged in on a webbrowser, this didn’t change the text either.

Hi @Peter_Groenewegen, Big thanks for taking the time to check and test!
It looks like we’ve stumbled upon a bug. We’d love to dive deeper into this, so I’ve gone ahead and opened a support ticket for you. You can keep track of it using the ticket number #916736. Our support team will reach out to you shortly!

Thank you so much for your help here!