Figma Support Forum

Copying text content with CTRL+C to WYSIWIG inserts figmeta

When I select text layer and press CTRL+C to copy it’s content to WYSIWIG editor (I use Wordpress and Elementor builder) I’ve got this https://i.imgur.com/UiRFdrh.png and I copied the simple text layer with content “About”
figma: https://i.imgur.com/RwSHuPQ.png
result: https://i.imgur.com/yO2UdH1.jpg

Yes, I can copy text with this button https://i.imgur.com/W0UGvXT.png and all works fine, but this is not very handy to switch between tabs with a mouse while your are codding. In my opinion this CTRL+C should work exectly like button above. Or maybe is there a way to add some hotkey (like CTRL+SHIFT+C) to copy only text content of the layer?

I’m also experiencing this. :pensive:

Try to paste not with Ctrl+V, but with Ctrl+Shift+V.

Wow, so easy solution, sorry for dummy question and thanks for answer!

Pasting without format isn’t a solution; it’s a work around. Better than nothing, but how to disable this nonsense?

You can easily destroy servers with that. I copied a few lines of text and Figma added nearly 400k characters to it. Totally crashed the server without a way to notice.

2 Likes

Would love to see a setting to disable this functionality.

This issue was brought up a while back: https://spectrum.chat/figma/general/exclude-figma-code-when-copy-and-pasting-text-into-wysiwyg-editor~a2a02823-22f6-41c0-8522-61c84404ba6e (can’t post links I guess?)

I’m about to review all the fields on my site to remove the extra content that was added, just glad that I caught it. I’d imagine that this issue has caused several other developers to unintentionally paste a whole heap of text into fields on their websites.

This is driving me crazy.

I know I can use cmd+shif+v, but sometimes I forget and then I have to redo the whole thing. So much wasted time.

I wish I can disable the function, when I want to copy the text from figma or why its not disabled automatically from DEV tab?