Copy / Paste Properties Breaks Links to Varables

I’m a frequent user of the copy properties action and this update has broken it it major way IMO. Say I copy an element that has a backgroundPrimary variable for its fill, pasting the properties onto another object will break that reference and the pasted object is using hex codes now. I’d assume this is a bug and hopefully not the intended behavior because it renders the paste properties action useless if you’re using the new variables/tokens system.


same thing.

I cannot use variables with this problem. it’s very frustrating(

1 Like

Hoping for a quick fix, this is quite time consuming

1 Like

It sounds like a must-have to me too. Otherwise, I wouldn’t make the move to variable as it’s too time consuming at the moment.

1 Like

Saw and cried…
Looking forward to update.

1 Like

Please report this as a bug through the bug report form in Figma


Bump. Our team is affected by this bug and it slows down our workflows.

1 Like

For anyone curious, I submitted this as a bug report and they’re aware of the situation and working on a fix. Hopefully they’ll get something out soon

1 Like

For anyone who doesn’t know how to report a bug:

Submit a report

  1. Click the question mark icon in the bottom-right corner of the screen.
  2. Select Contact support.
  3. Type anything in the Help text field and press Enter.
  4. Click the Contact us button.
  5. Select Report a bug from the options.
  6. Fill out the form by adding your name, email address, and information about what you’re experiencing. If possible, please include steps our team can use to reproduce the issue.
  7. Click Attachments to upload screenshots or videos of what you’re experiencing. You can add up to 5 files. Click the “X” next to a file to remove it from your report.
  8. Click Send to complete the process. The Figma support team will follow up with you via your email address.

Note: If you’re in the editor and don’t see the question mark icon, you may have disabled Figma’s Help UI. Open the menu and search for Hide help UI. Click on the setting to toggle it on.

I got this info from this page:

Hope this helps!