Component overrides get broken after library publish

We’re experiencing a random problem with component overrides in our design system which consists of multiple library files. Our components use an atomic structure, where small individual components are combined (sometimes with overrides) to create larger components.

The problem we’re facing
We’re using some components in a design file and they have overrides applied to them. When a new library update is published, taking the new updates in the design file breaks our overrides. The component properties/variant selection is intact, even the value of the overrides are intact, however the instance would either loose border radius, or have its alignment changed or the layer name resets to the original name from the atomic component. This happens to some specific components, and not others. And this also happens randomly, sometimes some components break, while others don’t.

We tried recreating the whole library from scratch with a few components to see if the problem persists, and unfortunately the instances still break.

Here’s an example of a list component that has a logo element which breaks on a new publish:

If you inspect the broken instance, you can see that the border radius has gone to zero. After toggling something back and forth from the component properties, the original value comes back.

I’ve created a detailed screen recording along with commentary showcasing this problem happening on a particular logo element: View screen recording

We’ve tried a lot of things and nothing seems to be working, so our assumption is that it might just be a bug. Is there something in the way the component is built that is breaking it? Or perhaps this is a known bug?
Any support will be appreciated. I’m happy to share more details needed to investigate this issue.

2 Likes

(I’ve shown this in the screen recording, but sharing it again as screenshots)

Here’s how the library files are structured:

And here is the components file:

2 Likes

I feel your pain – we have the same issue all over sudden. If I click on the broken layers, they jump back to correct, but as soon as I close the file and reopen it, it is back to corrupt.

I’m having exactly the same issue. Is there a fix for this?

2 Likes

I have this issue too

We are having a similar issue.

Here are the steps to reproduce this ( please see photos )

  • base component with 2 variants, a text property for the label is defined

  • parent 1 has an instance of base component

  • parent 2 has 2 instances of parent 1

  • change the text of the 2 instances in parent 2

  • change the variant of one of the instances in parent 2, the text override is maintained.

  • change the variant of Parent 1

  • the text override in the Parent 2 instances is reset if you change the Parent 2 instance’s variant, but sometimes, it does not

  • if you keep changing the Parent 2 instance’s variant and change the Parent 1 variant, eventually it will reset the Parent 2 instance’s text override

Just FYI, exposing properties from nested instanced in Parent 1 does not solve this issue either.
This issue started I think < 6 months ago, prior to that, this issue did not exist.
We could change the Cell width variant that was nested inside a default table row and it would completely preserve the text override and / or component swap inside the Cell