Change variant and open Overlay with position Manual

I want to change a variant and open an overlay with “Position: Manual” after a “click trigger” in Figma. The trigger performs both actions, but the overlay opens as “Centered” instead of “Manual.” Any suggestions? Thank you!

Hey Thomas,
Thanks for reaching out to the community! I try to replicate the Manual feature in overlays and it works on my end :thinking:
It looks like that you have added your interaction (the overlay) in your main component, but not in the frame where your instance component is located. In order to fix it, you have to create interaction in the frames where you want the actions to be done.

Can you also share quick video recording? Please include the whole window, with the properties and layers panels in view and relevant layers expanded, and select any layers you’re having trouble with so we can check any relevant settings.

It would be also great to have a copy of your file so we can try to replicate and investigate it further. If you are hesitant to share publicly here, feel free to reach out directly to the support team by filling this form: here

Be sure to use your Figma account email, include links to the file, and share it with so they can take a closer look.

Hi @Celine_Figma, Thanks for your answer! Here’s a video:

Thanks for the video! This seems buggy to me.
Can you please reach out directly to the technical team with your screen recording and a copy of your file and grant access (share it to by filling this form: here ! This will help us to investigate further.

In the meantime, as a workaround, the best option would be to create this interaction directly in the frame (and not in the main component) to see if this helps? I’ll pass also the mic to the community if they any other interesting workarounds! Thank you

1 Like