Can't remove accidental image from library color

Through some chain of events that I don’t remember exactly, I added an image to a color style definition in our shared library when I was experimenting with a design. But when I go to edit the style definition in the library, the image is not there (and I haven’t heard any other library users complain about it), so the problem must exist in my own file, but I can’t find how to undo it?

Below is the style as applied in my file. As you can see, it has a color and an image, and I cannot edit it from this file since it comes from the library. Every element that uses this color in my file now looks like this.

But when I click ‘edit in library’, everything there is fine? I’ve tried removing and re-adding the library to this file, but that didn’t solve it.

1 Like

You need to publish the changes you made to the library and then accept these changes in this file.

Maybe I wasnt clear in my description: there are no changes to the library. I somehow ‘contaminated’ a library style, but the library itself has no changes. I’m not even allowed to edit the library at all. But in my own file, when I use that green color from the library, it has an image included that’s not supposed to be there, and I don’t understand where that is stored or how to fix it.

1 Like

Hi @timh probably it might be helpful to take a look at your file. Would you mind sharing it with us?

Hi Yasuhiko, I’d love to, but the file is in a private Figma organization that would need authorization from the admin unfortunately. In the meantime I tried making a new draft file, adding the library there, and copying an artboard over to the new file, and then the bug is gone, so I might just move everything over.


Thanks for the reply! Them could you reach out directly to the support team with a copy of your file: You can get further support from our support team.

Please make sure you use the email associated with your Figma account, include links to the file in question, and share access with Don’t worry, inviting us to view your file won’t impact your billing.


I’m having the same issue. Breaking the style in the working file shows that there’s a random image fill layer. But, when I check that style in the library source file, there’s no image fill layer.




Just submitted a bug report for this issue^

1 Like

I’m having same issue. Is it resolved?

Their suggestion was: As our first steps, can you try making a ‘silent’ change to the color style in the library file and then publishing and accepting the update? To do this, select the color style and make a minor change like adding or editing a description and then publish and accept the update.

My fix was: The “quiet” update worked; not when editing the description (which I tried first), but when temporarily adding a new fill layer to the color style.

1 Like

Hey Kailyn, thanks for reporting back, I asked my library admin to perform the same silent update and it worked!

Thanks for the reply! I will definitely try this.