Can't Edit Restored Version from History ("View Only")

Wanting to Restore an old version and edit it, but its only giving me a View Only file.
What gives?
See screenshot. Next to filename:
“View Only”
I’m logged in.



To restore a version of a file, you need to click the three dots on the selected version and select “Restore this version”. Alternatively, you can right-click on the saved version and select “Restore this version”.

Relevant article from help center:

Please read my question.
“View Only”

Since you just selected (left-clicked) the checkpoint, you are in the preview mode for this version. To edit this version, you need to click “Restore this version”.

Editing a previously saved version is impossible without restoring it.

In my original message I should have mentioned that, yes, I did click “Restore this Version.” I just tried that sequence again on a different file, and upon clicking “Restore this Version” and it automatically refreshing, I’m still getting “View Only.”
(Yes, logged in.)

Glitch? Bug?

Screen Shot 2021-06-17 at 2.19.27 PM
Screen Shot 2021-06-17 at 2.19.52 PM

After completing the restoration of the version, you need to click the “Done” button at the top left. This will close the Version history Panel and then you can edit the file.

Could you record a video?


Ah, click “Done.” That’s the missing step.

Wow, tell your UX designer to eliminated that totally-not-clear, totally-unnecessary extra click immediately. I imagine I’m not the only one to be punched in the face by this, especially since the HelpCenter instructions say nothing about sending the cursor way over to the opposite side of the field to click the inconspicuous, blue “Done” button that does not appear to have anything to do with the operation. It’s like the equivalent of a vehicle engine’s kill-switch being some random-ass button behind the license plate instead of just turning back the ignition key.

Either your UX person needs to eliminate that random extra step, or the HelpCenter editor needs to fix this discrepancy (and all the others). (This is merely one of several discrepancies I’ve discovered amidst the HelpCenter instructions, each discovery preceded with a painstaking right cross to the face :persevere: and hell of a lot of time wasted :pensive:)

Check it out; instructions do not include “Done,” and (post clicking “Restore This Version”) UI does not include anywhere the words “Edit Current Version.” Oy vey :crazy_face:


Agree 100%. The DONE button is so far away from the actions you are taking I’m not sure who would ever even look for it there.

Thanks Meowface_Sam! This question helped me a lot!


Even when I tap the DONE button, it only exit the ‘view history’ and the design remains the latest version… The history version is not restored. :frowning_face:


I face the same issue. I Click restore & Done and nothing happens. I try to restore version from 6 days ago. Please help

same here. not able to restore and EDIT older versions.

even after pressing the DONE button. it worked in the past.

i guess the problem is, the DONE button is not really pressed/submitted. because after pressing it and reloading the tab, it is shown again NOT PRESSED.

btw: Also the restore and reload actions currently take unusually long times.

I’ve had the same problem as @Meowface_Sam. I didn’t see the “Done” button (that is why I ended up in this forum). I understand the need for the “Done” button, but the truth is that now, its location is not very intuitive. If this can help, I was looking for the “edit mode” in the same three dots menu where you can restore the version.
: )


I agree with this. I spent a ridiculous amount of time on the web trying to restore the older versions, only to realise that I had to tap on the DONE button that was so hard to find

I was facing the same problem and realized it was a very deceptive bug. I’m not sure if this will work for you, but I just had to select the individual elements for them to update their state.

So I just did a [cmd + A] to select all and then hit [Enter] a bunch of times until I got down to the lowest level in each group. As I selected each item, the changes appeared - I hope this can help you too.