BUG: My cursor automatically changes to the comment tool

Once I get in this file I can’t edit much of it because figma automatically changes my cursor to the comment tool.

This has happened two times after reading some comments. I somehow make it to stop switching my tool but don’t know what is causing this and how to make it stop.

1 Like

I’m experiencing the same thing. Will let you know if I figure it out.

1 Like

It’s really really annoying. I am using a Wacom tablet (also tried with magic mouse) and am on an older iMac 10.15.7 catalina. (can’t update to higher anymore).
When I use my macbook Air Ventura 13.1 and use the touchpad or Wacom I don’t have problems.

I use a magic mouse too (with an M1 Macbook Pro). I will try to turn it off next time it happens to see if that is the problem. Thanks!

Hey All,

Sorry to hear this!

Is this happening both in browser and using the desktop app? What troubleshooting steps have you tried so far?

  • logging out and back in
  • clearing your browser/desktop app’s cache
  • un-installing and re-installing the desktop app

If you’re using Windows, you may also want to verify whether or not Sticky Keys are enabled.

Also, when you’re stuck in the comments mode are you able to use other tool shortcuts (e.g. V for the move tool) to change your cursor back or does it continue to revert back to the comments mode?

It happens only happens with particular files so I fix it by re-opening the files or restarting the app, both work. I use the desktop app on my Macbook.

I tried pressing a lot of keys :sweat_smile: because maybe it had something to do with my shortcuts. It worked the first time (idk what I pressed) but not the second time.

I can change to other tools normally, using shortcuts or selecting the tool with the cursor, but right after I select the tool I need it reverts back to the comment tool and It happens with a random delay. Sometimes it is an instant switch, sometimes it takes 10 seconds (max) to switch back to the comment tool.

Thanks for the additional context, @Said_Quintero2!

Our support team says that other users have reported that clearing their desktop app cache has resolved the issue.

You can clear the desktop app cache on a Mac in the Help menu under Troubleshooting. If you’d prefer to manually clear your cache you can:

  1. Quit the Figma desktop app
  2. Open Terminal.app and enter the following command: rm -rf "$HOME/Library/Application Support/Figma"
  3. Try opening the desktop app again

Let us know if that helps!

I am trying to use the normal cursor and the comment tool turns on every time I click into a frame. Can anyone help me turn whatever this is off?

Hey @Marley_Smith,

We’ve merged your question with an existing topic with the same issue. Can you please try the solutions listed above & let us know if it helps? Thanks!