Account Owner can't edit text anymore

I’m the account owner (free version) and as of this morning, I haven’t been able to edit any text in Figma (eg the “T” text icon that normally appears at the top of the page is no longer there). I looked through various support articles and forums about this issue, and tried all of the potential solutions.

I’ve been using Chrome and haven’t had any issues before today so I don’t know what may have changed. I thought it may be an issue with the font, so I went into my Figma settings to download the font installer and then when I downloaded the font installer to my Mac nothing happened in Figma (eg my Figma settings still asked me to download the installer - this was after I closed out and reopened, checked also in Safari, etc etc).

Then I tried downloading the Figma desktop app for Mac and same issue - can’t edit text. I double-checked my Font Book in Mac and I re-enabled my font family, but again nothing changed in Figma after doing so.

Does anybody know what the issue might be? I also have 1 editor (my designer) and she said she also can’t edit text as of this morning so we’re both experiencing the same issue.

If you don’t see the “T” icon (and other editing icons), you don’t have access to edit the file. You will see “view only” text at the top:
Figma file view only mode, you can't edit this file

Hi Gleb,

It doesn’t say I have view only access (I’m the owner of the file) so not sure why I’m not able to edit

Screen Shot 2021-04-05 at 5.41.24 PM Screen Shot 2021-04-05 at 5.40.49 PMScreen Shot 2021-04-05 at 5.43.03 PM

That’s strange, I’ve never seen anything like this. Can you try logging out of your account and logging back in? It’s weir that you don’t see “view only” text yet it doesn’t show which project this file is located in, like if it was not yours. Can you move the file to a different project? But I’m afraid you won’t be able to if you don’t have access to the project it was moved to… Someone else from your team could’ve moved it.

Hi Gleb,

I logged out and back in and still no luck.

Looks like I can’t move this file to a different project.

For additional context, this file used to be owned by our previous designer but she transferred owner access to me before she left the company. I’ve had owner access for the past 1+ months with no issues… this only started happening this morning. Any other idea of what could’ve happened here?

So it looks like we don’t have teams or projects, just files that we’ve manually added email addresses to for view/edit access. I’m not sure where this file actually lives, so could a solution be to:
-Create a team
-Create a project
-Take this file and “Duplicate to your drafts”
-Take the duplicated draft and move the draft into the team’s project (and use that duplicated version going forward)?

Let me know if you think that’d fix the problem. Can’t think of any other solution to get editing back…

Duplicating the file would definitely be a solution, but this means you will lose version history and comments from the original file if there were any.

In short, the problem here is the following:

  1. The file was in a team with other editors.
  2. The file was moved by one of the editors to another team or their drafts, so you can’t edit it anymore.

So if you could find who from your team moved the file and get them to move it back, you would be able to continue editing the original file. If they can find it by name and “show in project”, they would be able to move it back to your team from that project/drafts folder.

If you are fine with duplicating it and losing comments/version history, that’s a fine option as well. Also you may want to share this issue with Figma support team via the support request form as this is something that has to be improved in my opinion.

1 Like

This exact thing has happened to me. Font problem - downloading the installer does nothing.

If you only can’t edit text while other editing capabilities are available, that’s a different issue. Check out this thread: Font problem - #9 by Velga

Maybe you accidentally locked the edit

Looks like I can’t move this file to a different project. I can’t see the other projects name under a dropdown where I wanna move except the draft. I am an admin purchased version.

Before the permission was view then I got the permission as editor still nothing shows under dropdown (projects)

Hey! Is your issue resolved? I’m facing the same issue and it’d be great if you could help. I’m the owner of the file (premium account) and can’t edit text/add text.
@Charlotte_Witter thanks!

I am facing same problem…not able to type and edit anything.
Please Help…

I’m using the browser version of Figma, and it appears that, suddenly, for all files I have access to, I am unable to edit the texts.

And, suddenly, it started working again.

1 Like

It’s 2023 and the same happened to me. Issue persisted even if I duplicate the file. My solution was to restore the version from last time I had used it and it was still fine. Now it’s working great.