Variables from an external library added to the file are not showing up when trying to assign them to a value of a local variable

Some of my colleagues have the same issue. They are editors in a file. The libraries are enabled, everything seems to be set properly. Did you manage to find a solution?

Correction: They are not editors, they have view rights in a file

Hello Figma Community! :wave:

Maybe you can help… I have created an external library of color variables that I would like to use in this file. I have added the external library that contains just color variables. Yesterday, I was able to assign a variable from this external library to variables in my local file. Today, the flyout shows no variables and just a message “No colors available”.

image

Has anyone experience this issue before? It was working yesterday. Nothing has changed overnight, and now the variables do not show up in the local file. Any help would be greatly appreciated!

Thanks!
Jeremy

Also having this issue!

Hey All, sorry to hear you were having trouble with your libraries and apologies for the delayed reply!

This sounds related to a bug that we had and launched a fixed for a few days ago. This should have fixed itself if you were able to relaunch or refresh your tabs.

Please let us know if you’re still having issues.

Hi! It seems that the issue persists. What the developers need to see are the variable names so they can implement the designs, but they still only see the HEX codes.

Hi yeah, issue is still persisting - tried reloading tabs and restarting the app also in the browser. Having to copy hex codes manually :frowning:

Hey @Stanislav_Carla and @Billy_Harris, sorry to hear you’re still having issues!

Can you please confirm what OS you’re using? Is this happening when using Figma in the browser and the desktop app?

We’ll pass this onto the team to investigate.

Sure, we’re using Windows 10 and it’s happening when using the desktop app.

Thank you for checking!

Thanks @Stanislav_Carla!

I’ll pass this onto our team to investigate further.

This is fixed for me now.

1 Like

Glad to hear that, @Jeremy_Knudsen!

Please let us know if you run into any further issues.

I’ve the same issue, suddenly variables from the connected library are not showing in design files. Tried to clear the cache, relaunch, even link it to a new test file. Any idea?

1 Like

Hey @Moataz_Galal_Eldin, sorry to hear this is happening. This is likely a new issue, since a fix for this topic has already been pushed.

Please reach out to the support team directly via this form for help: https://help.figma.com/hc/en-us/requests/new

Be sure to use your Figma account email, include a link to the file, and share it with support-share@figma.com so they can take a closer look.