Unable to insert images into Figma file

Hello to everyone.

Recently, I was unable to insert any images into my Figma file. A pop-up box appeared, stating, “The open file operation failed.”

I work with the Figma desktop app.

Has anyone had a similar experience? How did you resolve the issue?

Thank you to everyone who has read this far.

Hi @Selina3,
Thank you for reaching out the community!
To confirm, do you also see this issue if you try to select an image for fill in Figma opened in the browser?

  • Our supported browsers are Chrome, Firefox, Safari and Edge.
  • If the issue seems specific to the desktop app, it may be helpful to try clearing the desktop app cache (Help > Troubleshooting > Clear Cache and Restart).
    Please note that this will also clear any offline changes you have not synced and you may want to verify that any unsaved changes are synced as described here: Can I work offline with Figma?
1 Like

Hi Celine,
Thank you for your response.
There is no problem while using Figma in the browser. Simply not working properly in the desktop application.

I did clear the desktop app cache, but still not working.
Also, I tried to log into another macbook using my account and inserted images on Figma desktop app successfully. Therefore I wonder if my Macbook is the cause of the problem, but I am still unable to identify the problem behind it.
(I even checked the storage and it’s not full yet.)

Update: Problem Solved :tada:

I was able to resolve the issue after upgrading my MacBook to MacOS Sonoma. I believe that the problem is due to Apple recently updating the new iOS operating system as a whole.

1 Like

Thank you for the details and the update @Selina3 !
Yes, this seems to be related to the iOS operating system, happy to hear you have found a fix! :grinning:

1 Like