Spell check not working? (underlining correct spelling )

Hello there,

I’ve noticed that the Figma app on my Mac is highlighting correct spellings. I have already set the language to English in my profile. Could anyone please let me know if there are any solutions to this issue?

Here is a screenshot of what I meant. thanks :frowning:

Hey @Jenny_L, sorry to hear you’re having trouble with Spell check!

Can you try disabling Spell check then enable it again to see if that helps at all?

I’ve tried that and it didn’t seem to work out.

Can you try selecting other English versions or if using Auto-detect language helps?

Thanks. Can you please guide me on how to do that? This is what I am currently seeing on the Figma settings.

The only other option is to switch to Japanese. I tried setting it to Japanese and then switching back to English. it wouldn’t work I. I uninstall and reinstalled Figma and that did not work either. The browser version works fine tho…

From the Main Menu via the Figma icon > Text > Spell check > Select langauge from available list

FYI - the spell check feature on the desktop app is dependent on the selected language in your Mac under System Settings > General > Language & Region

If your Mac has a preferred language other than English, it may be the cause of this issue. Glad to hear that it’s working as expected via the browser.

Manually switching to ‘English’ worked! Thank you!!

1 Like