Shortcut for Local variables / token panel

When working with local variables and tokens I find myself constantly opening and closing the local variables panel. It would be nice to have a shortcut added for displaying and hiding that panel. If there is not a shortcut added in first version, then this action could be listed in the MacOS menu bar as a command, so that a custom MacOS shortcut could be added,

Hello @Harald_Skogland, thanks for sharing your feedback.
For now, you can display and hide the local variable panel via “Toggle variables” in the quick actions toolbar (click in the Figma logo in the top left), then write in the search bar “Toggle variables”. Hope this helps!

thanks that is useful :slight_smile: BTW, going off on a tangent, for me the shortcut is ‘cmd+/’. I assumed that is because I’m using a Norwegian Keyboard and use Norwegian language in MacOS(?). It’s not very practical as the forward-slash is all the way over on top of the numpad on my keyboard so two hands are almost needed. I tried to play around with ‘keyboard layout’ (language) option inside the keyboard layout panel but it didn’t change my short cut into being ‘cmd+,’ as in your screenshot. Do you know what causes the change or why they are different? Is it a Windows or MacOS thing? :slight_smile:

update - as I was writing this, I played around with settings, it was “cmd+/” first then I changed to US keyb and then back to Norw. keyb. again and now I also have “cmd+,” … this was kind of confusing :smiley:

1 Like

Thanks for flagging this! Yes, when you change your keyboard layout (https://help.figma.com/hc/en-us/articles/5665442977431-Select-keyboard-layout) + the language keyboard setting in your MacOS (both to Norwegian language), your shortcuts should work!

If you are experiencing any bugs, please let us know so we can investigate it further here: https://help.figma.com/hc/en-us/requests/new Thank you :slightly_smiling_face: