Reviewers unable to load branch review window on some files

I’ve added reviewers to branches in files from a particular project that has limited permissions. Reviewers are able to see the review and merge window appear, however it does not load, and gets stuck on “Pulling it all together”. Other attempts to test this process on other files (from Drafts, for example) worked just fine.

Reviewers are able to close the window and view the file itself, so it doesn’t seem that permissions are a factor here. Are there any other variables that may cause this window from loading completely?

Hey Brad i’m having the exact same issue. sorry I don’t have the answer to this because the exact same scenario happened to me and after googling around i can’t find an answer. I’ll keep looking though

Thanks @Barry_Lavelle ! Good to know we’re not alone in this. Figma support is working with me and can’t replicate the issue, so they think it may be network related. Have you done any investigating at that level?

Thanks @Brad_Bice Yeah it seems funny that it does it for some files but not others. i’d assume if it happened on all branches then I could definitely see network being a possibility but it’s not consistent as far as i can see. Some branches work but others don’t. I did read in the figma docs that for a user with ‘View’ access to review a branch request they must be a member of the original master file you are branching from. I’m not 100% sure though because the people i’m sharing with can view my original file and can make comments so i’d assume they can also access the branch. That said to dfouble check I went to the share permissions in the original master file and added them by email as being able to view, even though anyone at my org can access. I will test it out tomorrow to see if it worked but its maybe something you could try too