Prototype : Scroll is not fluid

Hi everybody ! Sorry for my bad english … :roll_eyes:

I’m creating a prototype and users will test it on tablet.

In my prototype i have some frame which are scrollable. My problem is that when i’m testing on tablet the scroll is not fluid and it seems to have performance issues. I don’t have this problem on Desktop.

I checked the memory manager and all is fine :
memory-manager

Do you have any ideas to help me to improve the scroll fluidity ?

Hey @Pole_UX_UI, thank you for reaching out! No need to apologise, I am not a native English speaker as well. I do understand your issue, I would like to get more information to investigate further.

Could you please confirm what device model you have and the OS version?
Are you using the Figma app or a browser? If you’re using the browser, can you confirm if the issue happens in any other browser on the tablet?

I’ve heard from other users that these crashes happen more frequently on out of date OS versions and where possible, suggest that you update your OS to check if it helps.

Thank you in advance!

@Gayani_S Thanks for your reply !

I’m using a Samsung Galaxy Tab S4 with Android 10 (i’ve the latest possible version for this tablet) and i try Figma preview directly with browsers FF and Chrome.

I also tried on Apple Ipad with Safari, i have the same issue.

Hey @Pole_UX_UI ,
Thanks for these details. I am working closely with Gayani :slight_smile:
This looks odd, I would also recommend to take a look at our guide on how to Reduce memory usage in files. Most of the suggestions provided in the guide can also be applied to improving prototype loading on mobile.

Figma is a browser-based app, which means it’s subjected to a 2GB available memory limit that applies to each browser tab, including those in our mobile app, or mobile browser. When loading or editing Figma files nears or exceeds this memory limit, it can cause performance issues like long load times or crashes, especially in a mobile browser which generally has an even smaller available memory (the specifics depend on the phone model and OS version).

If you’d prefer to troubleshoot your file without sharing it with us, to find out what’s using the memory we suggest creating a separate prototype of just the frame that’s crashing and testing the following to see if they help stabilize loading and the performance:

  1. Checking the impact of interactive components with variants. Because the presentation view currently loads all variants in a set, not just those used in a specific transition, using large variants sets for interactive components uses a lot of available memory. We’d suggest creating a set with only the states needed for a specific transition or disabling interactive components as needed.
  2. Removing hidden layers: Loading and then hiding many layers, especially in components or with images stored in them, can cause a high use of available memory on loading.
  3. Removing stacked masks and effects like shadows and blurs also take a lot of memory to load.
  4. Downsizing large images: You can check the size you’ve added an image to a File at by temporarily toggling the Image Fill settings to ‘Tile 100%’. If the preview you see is much larger than the Frame it’s filling, we’d suggest toggling this setting back, and then exporting the Frame and replacing the Fill with that export. You can also optimise image size in bulk using a plugin.

If you find that any of these help to stabilize loading, you can then decide if it’s best to remove them from your main file or to set up a streamlined version of the file for mobile viewing.

If this still doesn’t help, it would be great to investigate your issue further with a copy of your file. Please reach out directly to the support team: here
Make sure to use your Figma account email, include a url of your file and share it with support-share@figma.com as an Editor, so they can take a closer look. Thank you!