'Present' Prototype doesn't reflect component behavior

I have encountered a few issues when I switch to ‘prototype/present’ mode. Some behaviors I have set up in my components are not reflected in presentation mode. I’ve shared the issue in the screenshot I’ve attached.

Example 1:

  • I have a Button Component with 2 variants, “show less” & “show more”, with Hover set up in ‘prototype’
  • I have another Component with 2 variants using these buttons to show more or less text.
  • I use this second component in a panel set up as a variant component.
  • I used the panel in my design. When I switch to presentation mode, the hover behavior works fine; it switches from long to short text but keeps ‘show more’ as the button’s text and does not show less.

Example 2:

  • I have created buttons for a sidebar with hover and selected them as a variant. And instances for different icons.
  • used these buttons to create sidebars, changing the icons (different configurations of the bar as variants)
  • These bars are used on the right of side panels; for each variant, a different icon is ‘active’ and the other ones are ‘default.’
  • I use the side panel component in my design. When I switch to presentation mode when I hover over the buttons, it works; when I click on the buttons, it switches to the correct panel. But there is no blue background on the selected button anymore.

Does anyone know what I am doing wrong for losing some behaviors on the way?

Many thanks,

Hi there,

Thank you for getting in touch. Until I have a chance to review your file, it’s hard to say for sure, but have you checked for any conflicting interactions? Sometimes, I’ve noticed that interactions are set on both the main component and its instances, which can cause issues. In such cases, I usually reset all interactions on the instances to avoid any mix-ups in the prototype connections.

Could you share the file link with us? I’d be happy to take a closer look. If I can’t pinpoint the issue, I might suggest reaching out to our support team for further assistance.


Thank you :slight_smile:

I found the fix almost by mistake yesterday.
I have found the option ‘reset component state’ for some of the interactions, and it fixed my issues.

Thank you again for your answer.

1 Like