"Open overlay" resets main component scroll position BUG

Issue: Open overlay resets parent frame scroll position, even tho it is not checked. (Only new state prototype ones are scrolling up)

That’s it, as simple as that. I don’t know why.

1 Like

Hi @Valter_L I’ve tested this from my end but are unable to reproduce the issue. Can you try clearing your cache and see if it still recreates? If so mind sharing a example or video?

I’m having the same issue. Opening overlay resets the parent frame scroll, and checking the reset button and turning it back off does not change anything.

1 Like

@Valter_L @lindsey_duong Could you please try using the same prefix for your page and overlay frames, for example “Home / Page” and “Home / Overlay” and see if that fixes the issue?

Tried it, but it didn’t. It seems to be a flaky bug, since if I create a blank project and do it exactly the same way, it works. On the other project where there are old relations & new ones, same settings cause it to jump to top.

There are 2 identical settings here, one jumps to top, other doesnt. (the one that doesnt is a blank new frame, where popup modal was added the same way.

Thank you for the clarification and example. I have passed the information along and we are investigating further with our engineering team.

1 Like

having the same issue, one file we made yesterday works perfectly and one we made today has this problem

Has there been any updates on this topic?

1 Like

It appears that this issue is isolated to the main components and doesn’t affect instances of those components. Could you please share the specific use cases or scenarios where you are using a main component instead of an instance?

Any luck on this one? I’m dealing with the same issue. :frowning:

Having the same problem here for some time.
Using the new state management system, clicking and opening an overlay always resets the parent frame scroll position to the top, no matter if that option is on or off.

1 Like

Same issue. Any updates?

This is still an ongoing issue, which is a downer for prototyping.
There is a workaround though, it is not ideal but in the meantime it does the job.

You don’t check the box “reset scroll position” and you had to the target overlay :

  • After delay / scroll to 'insert top bloc name here" / Instant.

You can also do this when you close the overlay, which is a tad better animation wise.

Having this issue, any updates?

1 Like

Same issue here, any news?

Hey All, our team hasn’t been able to consistently reproduce to find a solution yet.

As mentioned above, we did narrow down that the issue seems to only occur with main components and not instances of those main components. Is anyone able to share specific cases or scenarios that you need to use a main component over an instance?

Sorry if I’m stating the obvious, but the tool tip right next to “State management” solved the issue for me, regrettably after much time spent trying to figure it out:
“Preserve scroll position is automatically applied when top-level frames have identical names or matching prefixes.”
So, after updating my frames to have matching prefixes, it worked flawlessly.

Here’s a super simplified example. (attached video) You can see the frames are prefixed with “drawer/”

(The key with prefixes is that you must use a forward slash- no dashes or anything else will work. It would also work if the frames have the exact same name, but that becomes too difficult with multiple frames.)

Hope this helps!