I want to fix an element when scrolling. When in prototype mode, the fixed position element disappears



Hello,

I want the ‘Request for Quote’ button and its background to fix position when scrolling. I manage to get it “fixed” in the prototype tab, but it then this button doesn’t appear in prototype mode. Please see pictures.

I’m not sure if I’ve set up constraints properly or not. It’s a long screen, so I don’t want it right at the bottom of the screen, I want it stuck at the Y 756 axis point. Not sure if its an auto layout issue either since I thought absolute position could override any issues with auto layout and fixed-position elements when scrolling.

Thanks.

Hi @Caroline_Keane ,
Thanks for reaching out the Community! It is odd, it should work when you select the “Fixed”.

To cover some bases in how to select “Fixed”:
You can only apply one scroll position to each object.

  1. Select the object, group or component in the canvas.
  2. Open the Prototype panel in the right sidebar.
  3. In the Scroll behavior section, select the Position dropdown.
    Choose : Fixed
  4. Click the present icon to view the prototype in Presentation view and see the results.

In order to have a deeper look into your prototype file, you can also share a link to an example file here so anyone can help find the cause.
Still, if you would prefer not to share your file publicly, you can temporarily invite a representative of the Support team to the file (support-share@figma.com) and shared link to the file in question - by filling the form : here

3 Likes

OK, I will do that- thanks.

1 Like

It’s no longer possible to keep a selection in fixed position when scrolling or resizing the screen. Unfortunately, Figma made this weird decision to have the selection stay in fixed position relative to top and not to bottom (if needed), and so if the selection is a tabbar, it has to be placed relative to top, and over scrollable content. This prevents a designer from presenting screens in Figma Design mode, and it also prevents developers from inspecting content that is underneath or masked by the tabbar. I think that Figma should allow fixed to bottom, so that the selection can stick to bottom when resizing or scrolling the screen, without obstructing the view of content that manager or developers need to inspect…

3 Likes

Have you found a solution? I reported this bug several months ago, I still don’t see any fix.

2 Likes

Is there a solution to this issue? I am still experiencing this.

1 Like

Please address this issue.

2 Likes

I am also getting this issue please help me with is

1 Like

I am still experiencing this. @Celine_Figma could you please make a tutorial video for this issue?

Hi @Sohel_Rana_UI_UX ,
Sorry to hear you are having trouble with the fixed position. You should be able to see the fixed position in your right panel. If you are not able to see it, I’d recommend you to reach out directly to the support team with a copy of your file in order to investigate further: here
Be sure to use your Figma account email, include a link to the file, and share it with support-share@figma.com, and a quick video recording of the issue on your end if you are able to, so we can take a closer look. Thank you!

I did it. but after applying the position fixed and opening the proto, the element going to vanish. It’s a bug I think.

3 Likes

Hey @Sohel_Rana_UI_UX , it seems odd. As requested, it would be great if you can reach out to the support team with a quick video recording and a copy of your file, so we can try to replicate. Please include the whole window, with the properties and layers panels in view and relevant layers expanded, and select any layers you’re having trouble with so we can check any relevant settings.

Please fill out the form here: https://help.figma.com/hc/en-us/requests/new Thank you!

1 Like

Screenshot 2024-01-16 at 12.22.55

Depending on you position where you want the element to be fixed, you should also setup Constraints. In my case, I wanted a button to be fixed down at the bottom of the screen, and it was missing after I applied the Fixed position (like you commented). But when I added constraints so the element is at the bottom centered, the Fixed position worked.

Good luck!

2 Likes

Thank you so much. This solves the issue!

1 Like

Solved!

Add the fixed element into a frame first.
Then set the frame to a ‘fixed’ scrolling position within the prototype settings.

Removing the autolayout from the parent worked for me

+1 to:

  • adding it to a frame,
  • setting it to fixed,
  • and setting the constraints to bottom centred,

I also had to close my proto preview and reopen it to get it to display

1 Like

I tried everything mentioned here and still the same issue: elements with constraints to center bottom, with no auto layout and set to be fixed (stay in place) are just not being shown at all, regardless I close and reopen preview mode.
Is there any other way? This looks like a bug for me and it’s really sad that something so simple like make an element stop at the bottom of the screen to be impossible to do in Figma so I am trying to find an alternative just for this.

1 Like

Hey @Raysa_Marcelino, sorry to hear you’re still having issues after trying the solutions above!

This may be something specific to the way your layers have been set up. Please reach out to the support team directly via this form for help: https://help.figma.com/hc/en-us/requests/new

Be sure to use your Figma account email, include a link to the file, and share it with support-share@figma.com, so they can take a closer look.