Fix bottom nav on screen with autolayout

I have a page that I need to use autolayout on because I need to be able to show interactions with accordions opening and closing. But it also has a bottom navigation bar that I wanted to stay stuck to the bottom of the screen.

I know that I can select “absolute position” and have the bar ignore autolayout, which solves the problem of it having fixed position when scrolling. But if I do that, when I open the accordions, they disappear under the nav bar because it is ignoring autolayout. There doesn’t seem to be a way to have it both ways, I don’t know if there is any other workaround? Or if this just a flaw in the way Figma’s autolayout works

So you have a page with autolayout and inside the page is the navigation bar?

Since the navigation bar doesn’t scroll with the page, it doesn’t have a parent > child relationship with the page and shouldn’t be part of the page autolayout.
Instead it should be set to fixed position:
image

Your layout hierarchy should go from (approximately):
image
to:
image

Thanks for your response. So, I did try that before, and the problem is I have to make the frame long enough to fit all the expanded accordions, which means when they’re not expanded there’s a lot of white space when you scroll all the way down. And if I don’t make that scroll frame long enough then they’re just cut off.

I can’t share the exact document because it’s an unfinished client project, but I made a new file replacing the content, if you can see what I’ve done and if there’s something to do differently: https://www.figma.com/file/IU0EDK7OBsdTZo8sdCzIjq/accordions?node-id=0%3A1

If I understand correctly, then you need to add a bottom padding (bottom nav height + spacing) in the parent frame’s Auto Layout settings.

And in your file, I see that Frame 161 and 162 do not have Auto Layout.

Your autolayout is set to fixed vertically. That’s why you get whitespace.
Your content grows so the space need to grow/shrink with it. Setting it to hug should fix it.

As tank666 says you need to add padding. Especially after setting autolayout to hug. But the built in padding is no good. You may need to use empty frames as substitute.
I was wrong, this isn’t true.

@Klesus @tank666
Thank you both so much for trying to explain. I’m still having some trouble understanding. Would either of you be willing to go into the file and edit it to show me what you mean? It is totally fine if not of course.

I see tank666 solved it with no fixed layers.
My solution do use fixed layers.

Go with whatever works best.

My file uses a fixed position for the bottom navigation. Open Presentation mode or duplicate the file in your drafts to learn more.

@tank666 @Klesus Thank you both so much! Both solutions seem to work so I will just try to apply either one to my design. I really appreciate your help, I’ve only used autolayout in very basic ways like with less elements involved so this was so helpful.