Figma Mobile App - Prototype Not Loading Correctly

Hello, loving Figma so far but I have run into a serious issue.

Everything was working fine in the prototype and now after simply adding more of the same frames and components that already had and that worked without any problems, now have problems loading certain frames.

Basically some of the colors and players aren’t rendering, the leaving only the text and background color. The navigational buttons still work, you can tap them and their hints are showing up (blue stuff), but you can see them. If I edit something in the file while the prototype is running, then it seems to refresh the frame and you can see everything but this is not a viable solution as the problem is ongoing. Also, even after that frame is refreshed, the error can still occur again in the same runtime when navigating away and then back to the problem frames.

I tested running the prototype in a browser instead of through the Figma mobile app and DID NOT encounter the same problems at all and everything worked correctly.

Because the layout is different when using a browser on mobile vs using the figma app, ie the top of the browser interface pushes everything down, it breaks the UX as it put certain things off the screen etc. So it is critical that the prototype is used with the mobile app instead of browser, unless there is some way on chrome mobile to remove the UI I guess. Still not ideal, would much rather get it working properly on figma app.

Not sure if I can add photos or if photos are necessary to help you give me the right solution. I’d rather not link to project to protect my intellectual property.

Problem is now happening on mobile browser as well. If the page is refreshed in the browser, the render is corrected until you navigate away and then back again, at that point same error of a black screen with text only.